Jump to content

Unable to detect hands with hand tracking sdk and Unity

Recommended Posts


I am new to unity and vive pro. I am trying to implement ray casting using the hand tracking sdk. I have already followed the steps mentioned in the documentation and verified that camera is working on SteamVR. However, my hands are not detected. The robot hands in the sample scene are static. They do not move according to my real hand.

I also tried to follow the steps as described in the VIVE hand traking SDK webinar - 

- I have added gesture provider script to main camera

- I have added left hand and right hand models; added hand display switch (script) and Hand state checker (script) to the models.

Yet my hands are not detected.

I get the below error

NullReferenceException: Object reference not set to an instance of an object
ViveHandTracking.ViveHandTrackingEngine.UpdateResult () (at Assets/ViveHandTracking/Scripts/Engine/ViveHandTrackingEngine.cs:107)
ViveHandTracking.GestureProvider.Update () (at Assets/ViveHandTracking/Scripts/GestureProvider.cs:157)

I am using unity version - 2019.4.28f1

hand tracking sdk version - 0.9.4

Am I missing out on something? Kindly help me resolve the issue.

Link to comment
Share on other sites

Hi @Shr

Have tried to run the sample scenes first?

You can try the UI sample scene, which is located at `Assets/ViveHandTracking/Sample/UISample.unity`. Just double click it from Project window and Hit Play.

Please also note that Hand Tracking SDK may take about 1-2 minutes to startup in the first run on each machine. Please wait for a few minutes, then put on HMD and verify if you can see your hands.

Link to comment
Share on other sites

I tried to run the sample. I see that there are two cartoon hands (the colored ones). But they do not move with respect to my actual hands even after waiting for about 5 minutes. Is there any additional setting that I am missing?

Link to comment
Share on other sites

Hi @Shr

Do you see any errors in Unity log console? Can you also provide the hand tracking log file, which is located in %USERPROFILE%\AppData\Local\Aristo\Aristo.log.

It seems a little strange to see cartoon hands after the start, since the default hand is the skeleton (spheres and links). Cartoon hand is only shown after both hands triggered thumb up gesture.

By the way, we have newer version 0.10.0, you can have a try and see if that helps.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...