Jump to content

VIVE PRO 2 with Elite Dangerous Horizons


Recommended Posts

Has anyone got it to work successfully with Horizons?

I can get it to load but I get constant errors in the SteamVR frame timings (pink lines) which causes awful ghosting and weird effects in the headset. The really weird part is if I UNFOCUS the game's window the head tracking still works and it's suddenly smooth and awesome - but then I can't actually interact with the game via mouse, keyboard or joysticks :(

I've tried reintalling the whole VIVE software, tried SteamVR beta, and moved to different USB port but no dice. 

Other true VR games like Beat Saber work flawlessly so it must be something to do with that game.

Link to comment
Share on other sites

Ok, managed to solve it.

It's all down to the lack of true "Motion Smoothing". HTC have their own implementation called "Motion Compensation" but as far as I can tell it doesn't really do anything (there doesn't seem to be any difference with it on or off), if it does do anything then it is only up to a certain point after which it just gives up and causes an error/missed frame and horrible ghosting/reprojection in the headset.

The solution was simply to turn off "Ambient Occlusion" to give that little bit of a performance boost and everything is now super smooth and no errors - weird or what?

Hopefully SteamVR will support proper motion smoothing in the future.

Link to comment
Share on other sites

On 6/4/2021 at 7:15 PM, MixedupJim said:

Ok, managed to solve it.

It's all down to the lack of true "Motion Smoothing". HTC have their own implementation called "Motion Compensation" but as far as I can tell it doesn't really do anything (there doesn't seem to be any difference with it on or off), if it does do anything then it is only up to a certain point after which it just gives up and causes an error/missed frame and horrible ghosting/reprojection in the headset.

The solution was simply to turn off "Ambient Occlusion" to give that little bit of a performance boost and everything is now super smooth and no errors - weird or what?

Hopefully SteamVR will support proper motion smoothing in the future.

One other tips is to disable the hardware accelerated GPU scheduling will help in some simulation games.
Some windows will auto enable that after update. worth to try. 

image.png.ac1829cb774d80ef2c8be9574eaa7f67.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...