Jump to content

[BUG] Eye Sample_v2 script can NOT correctly align blendshapes(Shape Tables) and input element columns ?


Recommended Posts

Hi, I'm new for Vive Pro Eye.
Now, facing a weird problem for SRanipal_AvatarEyeSample_v2 script.
Just like below figures show, the script can NOT correctly align blendshapes and input element columns.

This situation happens no matter in the ViveSR sample scene or my customized avatar, created by Character Creator3. It causes me can not control the facial expression of my customized avatar.
I guess it happened due to the Editor script; however, I can not find it in ViveSR folder.


Does anyone know how to solve it? Or do this bug happened due to Unity bug?
Thank!

 

ViveSR sample scene

1583593078_UnityBug_AvatarEyeSamplev2_(5).thumb.PNG.1981d269a6bade4372cfc2f7dd937568.PNG

 

My customized avatar

2022690824_UnityBug_AvatarEyeSamplev2_(2).thumb.PNG.af07be685642fdb7a0373965ae1a1aa3.PNG

 

SDK-v1.3.3.0

Runtime v1.3.2.0

Eye camera version 2.41.0-942e3e4

Unity version 2019.4.18f1

Link to comment
Share on other sites

  • 4 months later...
  • 3 weeks later...

Hi @agbastonb,

 

I didn't solve this problem until now. However, I used the stupid method to make the eye tracker work for my avatar successfully.

Because the SRanipal_AvatarLipSample_v2 has the correct input element columns., I just count which one I need in the EyeSample_v2 columns and align them one by one.

It sounds hilarious, but working!!!

 

Thank you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...