Jump to content

Jitter and Red Screen issues after an AMD driver update


Recommended Posts

Hello!
I'm borrowing my friends Vive, and when I got it from them originally in the summer, I  had the red screen issue. I fixed it by just using a different HDMI cable than what came with the vive. I recently updated my AMD graphics drivers (from 20.5.4 to 20.12.1). It was an optional update, and I chose the option to prevent me from rolling back to older versions, which I regret because now I'm getting the red screen issue again. Unfortunately, I only have the one monitor and one HDMI Slot on my GPU, so I have to fix this while in VR. It's possible to fix using Direct mode. Hooray!

Now, when I originally borrowed my friends Vive, using a different HDMI cable got rid of this problem *entirely* on its own, and everything was smooth sailing. Minus some tweaking and fiddling to get rid of jitter. I'm not sure what exactly I did, but I did get rid of the jitter and flickering that came up in The Lab, the VR Tutorial, and Steam VR Home. I know this system is VR capable, running an i3 and RX 570, I was able to run VR with the Vive smoothly, until this AMD driver update. Now, while I can get past the red screen (albeit with some great difficulty), I am facing the jitter again. Checking the timing graph it shows a lot of missed timing, something that didn't happen prior to the driver update. I cannot for the life of me remember what exactly fixed this the last time, and I would like to think that without any hardware changes over the last 5 months it shouldn't suddenly be incapable of running VR.

If there is any way I can get help on this, I'd appreciate it. 
P.S. I do plan to notify AMD of this as I do believe it is a driver issue more than anything else.

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...