Jump to content
 
Sign in to follow this  
Chocobo

Bluetooth connection failed.

Recommended Posts

I've had a Vive Pro for about a year now with two Base Station 2.0's and never had any issues until now after trying to install a third one. After trying all the solutions I could find online, I had finally given up and gone back to using two. It should be noted that despite the "Bluetooth connection failed. Check link box connections, then unplug and replug the power to the link box to reset it, then restart StreamVR" error I have never had any issues with my full body tracking or anything of the sort even after my failed attempt to add this third station. I have noticed the power management feature on SteamVR which runs through bluetooth no longer works for the base stations (They wont turn off when steamvr is off anymore) & thought maybe that the reason that I was unable to connect the bluetooth to my new station. I tried all the solutions to fix that error with no prevail as well including reinstalling SteamVR, all USB drivers, replacing the usb 3.0 cord with a 2.0 cord for the link box (now replaced back to 3.0). I have also triple checked to make sure that airplane mode is not on. I am out of ideas on what to do :( Thank you for your time!

1sD9UVn.png

Share this post


Link to post
Share on other sites

@Chocobo - The bluetooth driver situation is a common sticking point with SteamVR devices. Index users commonly see the same issue, I'd recommend looking at this thread to see some of the more updated troubleshooting steps people are taking (link)

In short, some users need to reinstall Win 10 to solve this issue. Some are able to manually uninstall the driver in Window's device manager and then manually reinstall the driver. Some people

  • Deactivate the Bluetooth communication from SteamVR > Settings.
  • Manually install the Bluetooth driver. You can run the installer manually from: /Steam/steamapps/common/SteamVR/tools/lighthouse/bin/win64/vivebtdriver.exe
  • Power cycle the link-box, re-enable Bluetooth communication within SteamVR, then test the issue

You will need to get the bluetooth comms working again to enable basestation power management. Without power management - your basestations will have a shorter lifespan so it's worth troubleshooting this problem, even if it requires you to ultimately use the nuclear option of reinstalling win 10.

That said, you can still technically add on the third basestation manually without bluetooth. Basestations ship on ch 1 of 16 be default. On the back of the unit there is a pinhole. While the device is powered on - you can carefully press that button a few times with a paperclip to change the channel to one that's not occupied by your other two stations (which are likely on 1 and 2 if you used auto config). It's a simple index system, starts at Ch 1 and each press increases the nchannel until you hit Ch16 upon which the next button press loops back over to Ch1.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...