Jump to content
 
shashkes

Direct Preview in unity not working - help

Recommended Posts

Could you try ping the ip address again?

Is it still the same?

Usually I will do the following steps,

1. Update IP Address to the Direct Preview Config

2. Install Device apk

3. Start streaming server

4. Start device apk

5. Play Unity Editor

If this fails, stop device apk and streaming server and try again from step3.

NOTE: If it connects successfully, the streaming server will keep printing lots of logs.

One more thing is that when you stop device apk, make sure you did not just exit by pressing the system button on controller button.

It will be better to re-install the device apk to ensure it is completely exited.

Share this post


Link to post
Share on other sites

so I got some advice from someone else at vive that seemed to help actually start the sever but still getting time out errors, and yes i checked the ip of the device and reinstalled and went through the process you outlined.
The advice i got was to go into Nvidia control panel and make sure the gpu of NVIDIA was selected (in mine it was on auto select, you can see the image attached). I needed to re enable the intel card to get into nvidia control panel. This is the log that i get now, so you see nvidia is in [0] location and it seems to actually start.

after I start device apk should it say connected? Is there some time limit that i need to start unity while it is trying to connect?  I've been trying different things but nothing works 😞 it seems so close now that server is starting.

The server config:.\config\serverSetting.setting is loaded!
The HmdList is loaded! 1 2
OnPipeInfo : Pipe Server Started
Pipe accept begin.
[2020-10-16 14:43:08.312 -7 4152 DEBUG logger] [Main] Set Log level as DEBUG

[2020-10-16 14:43:08.318 -7 4152 INFO logger] [Main]dpServer Version: 0.4.5.3

[2020-10-16 14:43:08.318 -7 4152 INFO logger] [Main]Init() Config from json: H265:false, Bitrate:23000000, GOP:100, EncodeHQ true, AllIFrame false
, ForceToSendTexture false, WaitDecodeDoneTimeOut 40 ms, fps 75,LogToFile:false,RTPPayloadSize:1400

[2020-10-16 14:43:08.324 -7 4152 INFO logger] [Main] GetGpuType() There are 3 adapter

[2020-10-16 14:43:08.325 -7 4152 INFO logger] [Main] GetGpuType() The GPU [0] is Nvidia!

[2020-10-16 14:43:08.325 -7 4152 DEBUG logger] OnPipeInfo(): Pipe Server Started

[2020-10-16 14:43:08.466 -7 4152 INFO logger] [CServerIns]openServer() url:rtsp://192.168.137.1:6555/live

[2020-10-16 14:43:08.469 -7 13668 INFO logger] GetMixFormat() ----- from audio end point -----, wFormatTag:65534
[2020-10-16 14:43:08.469 -7 13668 INFO logger] nChannels:2
[2020-10-16 14:43:08.470 -7 13668 INFO logger] nSamplesPerSec:48000
[2020-10-16 14:43:08.470 -7 13668 INFO logger] nAvgBytesPerSec:192000
[2020-10-16 14:43:08.470 -7 13668 INFO logger] nBlockAlign:4
[2020-10-16 14:43:08.470 -7 13668 INFO logger] wBitsPerSample:16
[2020-10-16 14:43:08.470 -7 13668 INFO logger] cbSize:22
[2020-10-16 14:43:08.470 -7 13668 INFO logger] wValidBitsPerSample:16
[2020-10-16 14:43:08.470 -7 13668 INFO logger] wSamplesPerBlock  (valid if wBitsPerSample ==0):16
[2020-10-16 14:43:08.470 -7 13668 INFO logger] GetMixFormat : PCM data
[2020-10-16 14:43:08.476 -7 13668 INFO logger] GetBufferSize :48000

image.png

Share this post


Link to post
Share on other sites

BTW I tried to get this to work on another computer and after updating Nvidia drivers there and starting the server i'm still getting a time out error. Can there be something wrong with the headset?

Share this post


Link to post
Share on other sites

Could you paste the actual error log?

And, is it showing in the headset or command prompt?

Share this post


Link to post
Share on other sites
On 10/16/2020 at 10:40 AM, shashkes said:

Unity 2018.4 LTS + Wave SDK 3.1.94 as recommended here: 

 

Could you provide detailed version (2018.4.x) of Unity Editor?

And please update Wave SDK to the latest version, and try again.

Share this post


Link to post
Share on other sites
On 10/16/2020 at 5:10 PM, chengnay said:

Could you try ping the ip address again?

Is it still the same?

Usually I will do the following steps,

1. Update IP Address to the Direct Preview Config

2. Install Device apk

3. Start streaming server

4. Start device apk

5. Play Unity Editor

If this fails, stop device apk and streaming server and try again from step3.

NOTE: If it connects successfully, the streaming server will keep printing lots of logs.

One more thing is that when you stop device apk, make sure you did not just exit by pressing the system button on controller button.

It will be better to re-install the device apk to ensure it is completely exited.

If you saw connection timeout, you can repeat step 4 instead of step 3, just keep the streaming server up running.

Simply stop device apk and start again.

@shashkes Is your problem resolved?

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...