Jump to content
 
d.b_mann

SRanipal UE4.24 FrameWork Missing and Package Error

Recommended Posts

Hello everyone,

I´m using the Vive Pro Eye for academic research.

My goal is to implement the eye tracker for my UE4 (Blueprint based) Project.

Downloaded and installed SDK v1.3.0.9 and started up  the Demo Scene (EyeSample). So far everything seems to work fine.

When Im trying to package that sample scene as stated in the instructions, the packaging results in an Unknown Cooking Error. (I am not using a lip tracker nor do i need to)

I tried to follow along the Instructions given in the SDK download. As seen in the attached jpeg. "SRanipal_Eye_Framework under: SRanipal C++ Classes/SRanipal/Public" is  missing.

On: Windows 10 , 64Bit

 

Any help or feedback would be apreciated.

Cheers,

Dominik

 

 

SRanipal C++.jpg

package error.jpg

 

@MariosBikos_HTC

Share this post


Link to post
Share on other sites

Hi @d.b_mann,

you are right, the reason you are getting this error is because after SRanipal v1.3.0.9, Lip Tracking is enabled by default so if you don't want any lip tracking functionality you need to disable the "Enable Lip by Default" settings tick box in SRanipal Project Settings of your UE4 project (see image). If you untick the box you should be able to package without errors. We will update the documentation to highlight this change. Thanks for reporting this 😉

 

image.thumb.png.04a72bb52c39c7ccc71281e528a5f853.png 

  • Like 1

Share this post


Link to post
Share on other sites

Hi, Im actually having a similar issue (except it doesnt even tell me Sranipal plugin is the issue like with d.b_man) I just know when I remove the plugin I can package fine.

I tried what you've mentioned above which didnt seem to work, but noticed when I toggle either the Lip or Eye checkboxes on and off I get a similar errors.
Im also running in 4.24. I wasnt able to build before, so I just updated today to try it again.

Any other possible ideas?

Thanks!

image.png

Share this post


Link to post
Share on other sites

Hey @zgibsontheia,

have you tried initialising the SRanipal runtime first? If you have a Vive Pro Eye device and the SRanipal is properly initialised then ticking the first tick box should initialise eye tracking in Unreal properly.
For the Lip framework you need to have a Lip Tracker device otherwise it won't work so you need to disable it.

Please also try the latest version of sRanipal v1.3.1.0 that comes with some changes on that front: https://developer.vive.com/resources/vive-sense/sdk/vive-eye-tracking-sdk-sranipal/

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...