Jump to content
 
Sign in to follow this  
TrevorAustin

Bad artifacting with motion smoothing

Recommended Posts

Posted (edited)

I turned on motion smoothing yesterday, using beta on vive and steam. Within Iracing there was the odd little flicker but overall a great experience. I tried it in project cars 2 today and the screen was full of little glimmering flashes. Turning off the motion smoothing without even unloading the game instantly fixed it, and turning it back on made it bad again. Just randomly appearing all over the screen, very odd and off putting. Going back to Iracing I can see it is happening a little bit but nothing like in PC2. Is this a known issue?

Edited by TrevorAustin
Typo

Share this post


Link to post
Share on other sites

@TrevorAustin - Motion smoothing is an interpolation technology created by Valve. It's going to look different not just with each different piece of content since it's applied at runtime but on each different PC loadout because each GPU is going to need to interpolate a different number of frames. Project Cars and iRacing (and other racing games) are well known examples of games that can have compatibility issues with interpolation technologies because the games are hard-coded with built in algorithms which smooth out the view and lock the players viewpoint (see here).

That simmering can often be specifically attributed to the SteamVR compositor switching between motion smoothing and asynchronous re-projection.

In these cases, disabling motion smoothing and other interpolation technologies would be the solution because the root of the issue is how the game itself is hard coded to render.

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, TrevorAustin said:

I turned on motion smoothing yesterday, using beta on vive and steam. Within Iracing there was the odd little flicker but overall a great experience. I tried it in project cars 2 today and the screen was full of little glimmering flashes. Turning off the motion smoothing without even unloading the game instantly fixed it, and turning it back on made it bad again. Just randomly appearing all over the screen, very odd and off putting. Going back to Iracing I can see it is happening a little bit but nothing like in PC2. Is this a known issue?

@TrevorAustin how did You enable motion smoothing in Steam VR for Cosmos/Cosmos Elite? I thought it's not supported for these HMD - I don't even have option to turn it on. Is it related to using SteamVR in beta branch?

Share this post


Link to post
Share on other sites

 

That would interest me too. 

Unfortunately, Cosmos seems to be the only HMD that doesn't implement this technique well.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...