Jump to content

SRWorks SDK Release 0.9.3.0 Crash on Unreal Engine 4.25


Recommended Posts

I am using Unreal engine 4.25.3 and I am working on VR project, I want to use SRWorks SDK – 0.9.3.0 to Enable Camera on HTC Vive Pro.

I have NVIDIA GeForce RTX 2070 and all drivers are updated and USB cable is plugged in 3.0 USB port and on Steam VR Testing camera is worked.

When I compile my project everything works fine but I have crashes in the StartFramework function when I press play: Unhandled exception at 0x00007FFCE7A89709 in UE4Editor.exe: Microsoft C++ exception: boost::interprocess::interprocess_exception at memory location 0x0000001858376CF0.

My Old Version Of project was on Unreal engine 4.18.3 and It was working well.

What should I do ?

Link to post
Share on other sites
On 7/12/2020 at 9:56 PM, Eyad said:

imageproxy.php?img=&key=6a3749c85cdc35aeimageproxy.php?img=&key=6a3749c85cdc35ae

I am using Unreal engine 4.24.3 and I am working on VR project, I want to use SRWorks SDK – 0.9.3.0 to Enable Camera on HTC Vive Pro.

I have NVIDIA GeForce RTX 2070 and all drivers are updated and USB cable is plugged in 3.0 USB port and on Steam VR Testing camera is worked.

When I compile my project everything works fine but I have crashes in the StartFramework function when I press play: Unhandled exception at 0x00007FFCE7A89709 in UE4Editor.exe: Microsoft C++ exception: boost::interprocess::interprocess_exception at memory location 0x0000001858376CF0.

My Old Version Of project was on Unreal engine 4.18.3 and It was working well.

What should I do ?imageproxy.php?img=&key=6a3749c85cdc35ae

@Daniel_Y

Link to post
Share on other sites
  • 4 weeks later...
On 8/11/2020 at 3:36 PM, wenjiec_shen said:

Hi Eyad,

I am sorry for the inconvenience.
In the version 0.9.3.0, the project SRWorks (XR) SDK UE4 Samples doesn't support Unreal Engine 4.24 but the project SRWorks (XR) SDK UE4 Plugin have supported it.
Are your project based on  SRWorks (XR) SDK UE4 Samples?
Thank you.

No, Its based On SRWorks (XR) SDK UE4 Plugin

but when I try to print status Variable in ViveSR inside TestKey blueprint It gives ERROR

This is my log, sorry there is error when I attached text file here 

Thanks for Reply 

 

LogTemp: Repeating last play command: VR Preview
LogBlueprintUserMessages: Early PlayInEditor Detection: Level '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel' has LevelScriptBlueprint '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample' with GeneratedClass '/SRWorks/Levels/Sample/Sample.Sample_C' with ClassGeneratedBy '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample'
LogPlayLevel: PlayLevel: No blueprints needed recompiling
PIE: New page: PIE session: Sample (Aug 16, 2020, 12:23:37 PM)
LogPlayLevel: Creating play world package: /SRWorks/Levels/Sample/UEDPIE_0_Sample
LogPlayLevel: PIE: StaticDuplicateObject took: (0.002722s)
LogAIModule: Creating AISystem for world Sample
LogPlayLevel: PIE: World Init took: (0.000959s)
LogPlayLevel: PIE: Created PIE world by copying editor world from /SRWorks/Levels/Sample/Sample.Sample to /SRWorks/Levels/Sample/UEDPIE_0_Sample.Sample (0.003844s)
LogUObjectHash: Compacting FUObjectHashTables data took   3.63ms
LogAudioMixer: Display: Audio Mixer Platform Settings:
LogAudioMixer: Display:     Sample Rate:                          48000
LogAudioMixer: Display:     Callback Buffer Frame Size Requested: 1024
LogAudioMixer: Display:     Callback Buffer Frame Size To Use:    1024
LogAudioMixer: Display:     Number of buffers to queue:           2
LogAudioMixer: Display:     Max Channels (voices):                32
LogAudioMixer: Display:     Number of Async Source Workers:       0
LogAudio: Display: AudioDevice MaxSources: 32
LogAudio: Display: Using built-in audio occlusion.
LogAudioMixer: Display: Initializing audio mixer.
LogAudioMixer: Display: Audio Device Output Speaker Info:
LogAudioMixer: Display: Name: VIVE Pro (NVIDIA High Definition Audio)
LogAudioMixer: Display: Is Default: Yes
LogAudioMixer: Display: Sample Rate: 48000
LogAudioMixer: Display: Channel Count Used: 2
LogAudioMixer: Display: Device Channel Count: 2
LogAudioMixer: Display: Channel Order:
LogAudioMixer: Display: 0: FrontLeft
LogAudioMixer: Display: 1: FrontRight
LogAudioMixer: Display: Using Audio Device VIVE Pro (NVIDIA High Definition Audio)
LogInit: FAudioDevice initialized.
LogSlate: Updating window title bar state: overlay mode, drag disabled, window buttons hidden, title bar hidden
LogLoad: Game class is 'BP_CollaborativeViewer_GameMode_C'
LogWorld: Bringing World /SRWorks/Levels/Sample/UEDPIE_0_Sample.Sample up for play (max tick rate 0) at 2020.08.16-09.23.37
LogWorld: Bringing up level for play took: 0.000829
LogOnline: OSS: Creating online subsystem instance for: :Context_10
LogGameMode: Display: Match State Changed from EnteringMap to WaitingToStart
LogGameState: Match State Changed from EnteringMap to WaitingToStart
LogGameMode: Display: Match State Changed from WaitingToStart to InProgress
LogTemp: Error: [ViveSR] ViveSR_Initial PassThrough failed. -3
LogTemp: Error: [ViveSR] ViveSR_Initial PassThrough4K failed. -3
LogTemp: Error: [ViveSR] ViveSR_Initial Depth failed. -3
LogTemp: Error: [ViveSR] ViveSR_Initial DepthMesh failed. -3
LogTemp: Error: [ViveSR] ViveSR_Initial Reconstruction failed. -3
LogTemp: Error: [ViveSR] ViveSR_Initial Controller failed. -3

LogViveSR: Warning: Start Framework: -3
Cmd: vr.bEnableStereo True
LogLevel: Warning: EnableInput on a LevelScript actor can not be specified for only one PlayerController.  Enabling for all PlayerControllers.
LogGameState: Match State Changed from WaitingToStart to InProgress
PIE: Play in editor start time for /SRWorks/Levels/Sample/UEDPIE_0_Sample 1.017
LogBlueprintUserMessages: Late PlayInEditor Detection: Level '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel' has LevelScriptBlueprint '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample' with GeneratedClass '/SRWorks/Levels/Sample/Sample.Sample_C' with ClassGeneratedBy '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample'
LogBlueprintUserMessages: [TestKey_30] ERROR 
LogAudioMixer: Display: No commands were queued while flushing the source manager.
LogAudioMixer: Display: No commands were queued while flushing the source manager.
LogBlueprintUserMessages: Early EndPlayMap Detection: Level '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel' has LevelScriptBlueprint '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample' with GeneratedClass '/SRWorks/Levels/Sample/Sample.Sample_C' with ClassGeneratedBy '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample'
LogSlate: Updating window title bar state: overlay mode, drag disabled, window buttons hidden, title bar hidden
LogWorld: BeginTearingDown for /SRWorks/Levels/Sample/UEDPIE_0_Sample
LogSlate: Window 'CollabViewer Game Preview Standalone (64-bit/PCD3D_SM5)' being destroyed
LogAudioMixer: Display: No commands were queued while flushing the source manager.
LogViveSR: Warning: Stop Framework: 0
LogWorld: UWorld::CleanupWorld for Sample, bSessionEnded=true, bCleanupResources=true
LogSlate: InvalidateAllWidgets triggered.  All widgets were invalidated
LogPlayLevel: Display: Shutting down PIE online subsystems
LogBlueprintUserMessages: Late EndPlayMap Detection: Level '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel' has LevelScriptBlueprint '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample' with GeneratedClass '/SRWorks/Levels/Sample/Sample.Sample_C' with ClassGeneratedBy '/SRWorks/Levels/Sample/Sample.Sample:PersistentLevel.Sample'
LogSlate: InvalidateAllWidgets triggered.  All widgets were invalidated
LogAudioMixer: Display: No commands were queued while flushing the source manager.
LogUObjectHash: Compacting FUObjectHashTables data took   3.27ms
LogPlayLevel: Display: Destroying online subsystem :Context_10
LogSlate: Window 'Output Log' being destroyed


@wenjiec_shen

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...