Jump to content
 
C.T.

Cosmos Beta release - 1.0.12.10

C.T.

We are collecting feedback for newly added feature - desktop mode.
Please kindly leave your comment here 🙂 

Thanks

Message added by C.T.

Recommended Posts

3 hours ago, Gosbot said:

Performance isn't any better for me. I wish we had the ability to roll back to older versions of the software so that I could test the extent to which my performance has degraded since 1.0.12.4a and make sure there isn't something wrong on my end.

PM me, I'll help you roll back to previous public version 1.0.11.2 if you like 

Share this post


Link to post
Share on other sites
22 hours ago, C.T. said:

PM me, I'll help you roll back to previous public version 1.0.11.2 if you like 

Thanks, I ran a benchmark of my current performance and messaged you so that I can try testing if there's any difference between it and 1.0.11.2.

Share this post


Link to post
Share on other sites

Here’s my conclusion on the recent state of performance regarding Cosmos. Every time that the VR application that opens on the desktop when you launch a game is the active window on the PC, performance tanks inside the VR headset. The SteamVR performance graph becomes purple, and the visual experience within the HMD becomes a blurry, stuttering nightmare- that is, if the application is intensive enough in the first place. I used the VRMark Blue Room to benchmark, and the difference between running the program as the active window vs in the background on the PC was astronomical. I got similar results in Half Life: Alyx and Boneworks.

So, why does it seem like performance has tanked in newer versions of the Cosmos software? I’ve been able to test 1.0.11.2 and 1.0.12.4a side by side (thank you, @C.T.) and I don’t think that it’s the version of the software itself that has affected performance. With both versions, I would get severe lag until I prevented my game from being the active window, which would then return my performance to the silky smooth experience I remember from when I first got my Cosmos Elite in April. Instead, there is probably a more general issue with how any version of the software interacts with newer versions of SteamVR or Windows such that when launching games from within the headset, they now launch as the active window. I am convinced that games did not, for one reason or another, launch this way at one point, since I used to always get the great performance that I now have to take an extra step to achieve.

TL;DR- Running VR applications as the active window on the PC tanks performance in the Cosmos. Launching games from within the headset makes them the active window on your PC by default, which I don’t think used to happen. To fix your VR performance, open a browser tab on your computer to ensure that the VR game isn’t the active window.

All my testing was done on a system with a GTX 1070, R5 3600, and 16 GB of RAM on Windows 10 2004. I cannot guarantee that this fix will work for everyone, but I am positive that it worked for me. This fix would also explain why some people have claimed that changing process priorities in task manager resolved their performance issues. It's not the actual changes they make in task manager that help them, it's that opening task manager involves them stopping the running VR app from being the active window.

 

Share this post


Link to post
Share on other sites
49 minutes ago, Gosbot said:

Here’s my conclusion on the recent state of performance regarding Cosmos. Every time that the VR application that opens on the desktop when you launch a game is the active window on the PC, performance tanks inside the VR headset. The SteamVR performance graph becomes purple, and the visual experience within the HMD becomes a blurry, stuttering nightmare- that is, if the application is intensive enough in the first place. I used the VRMark Blue Room to benchmark, and the difference between running the program as the active window vs in the background on the PC was astronomical. I got similar results in Half Life: Alyx and Boneworks.

So, why does it seem like performance has tanked in newer versions of the Cosmos software? I’ve been able to test 1.0.11.2 and 1.0.12.4a side by side (thank you, @C.T.) and I don’t think that it’s the version of the software itself that has affected performance. With both versions, I would get severe lag until I prevented my game from being the active window, which would then return my performance to the silky smooth experience I remember from when I first got my Cosmos Elite in April. Instead, there is probably a more general issue with how any version of the software interacts with newer versions of SteamVR or Windows such that when launching games from within the headset, they now launch as the active window. I am convinced that games did not, for one reason or another, launch this way at one point, since I used to always get the great performance that I now have to take an extra step to achieve.

TL;DR- Running VR applications as the active window on the PC tanks performance in the Cosmos. Launching games from within the headset makes them the active window on your PC by default, which I don’t think used to happen. To fix your VR performance, open a browser tab on your computer to ensure that the VR game isn’t the active window.

All my testing was done on a system with a GTX 1070, R5 3600, and 16 GB of RAM on Windows 10 2004. I cannot guarantee that this fix will work for everyone, but I am positive that it worked for me. This fix would also explain why some people have claimed that changing process priorities in task manager resolved their performance issues. It's not the actual changes they make in task manager that help them, it's that opening task manager involves them stopping the running VR app from being the active window.

 

To be clear, to get better performance I just have to have the game window minimized, or have a browser window pulled up? 

Share this post


Link to post
Share on other sites
20 minutes ago, Wolf_Spider said:

To be clear, to get better performance I just have to have the game window minimized, or have a browser window pulled up? 

Yup. Interacting with any application that isn't the one running in the VR headset does the trick, even just hitting the Windows key to bring up the start menu. If you want to see if it helps you out at all, I would set the headset on the floor in any area of a certain game where you are having performance issues and then bring up the SteamVR performance graph. If clicking in and out of the application seems to correlate with trends on the graph (for me, the graph would be purple with the game window active, and green after clicking out of the window), you are probably affected with the same issues I am. 

Share this post


Link to post
Share on other sites

Update: I found the exact cause of the scenario I’ve been describing. It’s hardware-accelerated GPU scheduling, a recently added feature to Windows that claims to “reduce latency and improve performance.” If you’re using this feature, you probably want to disable it. If you aren’t and you still have performance issues that have arisen recently, I don’t know what to recommend other than the generic troubleshooting techniques like resetting the HMD from the console and checking your SteamVR resolution settings. From my benchmarking, Cosmos 1.0.11.2 and 1.0.12.10 Beta run pretty much the same, though it’s always possible that might be different on your system.

  • Like 2

Share this post


Link to post
Share on other sites
On 7/5/2020 at 4:40 AM, Gosbot said:

Update: I found the exact cause of the scenario I’ve been describing. It’s hardware-accelerated GPU scheduling, a recently added feature to Windows that claims to “reduce latency and improve performance.” If you’re using this feature, you probably want to disable it. If you aren’t and you still have performance issues that have arisen recently, I don’t know what to recommend other than the generic troubleshooting techniques like resetting the HMD from the console and checking your SteamVR resolution settings. From my benchmarking, Cosmos 1.0.11.2 and 1.0.12.10 Beta run pretty much the same, though it’s always possible that might be different on your system.

This feature is reliant on the updated NVIDIA and AMD (beta) drivers. I'd certainly disable it for the time being as it's a very new feature.

Share this post


Link to post
Share on other sites

@C.T. Desktop mode look is good and is working well for me. The only issue is that I've noticed (unless I've missed it), is there is no way to right-click. Can this be added?

At the moment I am going back to the Steam desktop mode if I need to right-click on something.

Share this post


Link to post
Share on other sites
14 hours ago, Beta_Tester said:

@C.T. Desktop mode look is good and is working well for me. The only issue is that I've noticed (unless I've missed it), is there is no way to right-click. Can this be added?

At the moment I am going back to the Steam desktop mode if I need to right-click on something.

right click should be bumper key "A"/"X".  try it 

Share this post


Link to post
Share on other sites
On 7/1/2020 at 12:17 PM, hamez88 said:

am i the only one wondering what happened to updates 1.0.12.5 to 1.0.12.9

Take a look at all Internet Explorer iterations... there must be hundreds... no... thousands of versions missing!!!
There's no excuse... I need access to those, I just don't care about the latest release....

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...