Jump to content
 
cru89

Pass-through stopped working

Recommended Posts

Hi there,

I am working on an application that uses the SRWorks pass-through mode with a Vive Pro in UE4. Until yesterday everything worked fine, however the cameras suddenly stopped sending out images. I can't even run the Experience_Unreal sample or create a blank project - all I see are the default textures. I've attached a screenshot of the VR preview, which mirrors the right eye. On the left eye, I am seeing the default brick wall texture. Also, when I turn my head, I can see, that those textures are simply put on a plane, which is not following my head (as expected).

I already tried a number of possible solutions, none of which worked. The things I have tried include:

  • Repairing SRworks
  • Uninstalling and reinstalling SRWorks
  • Reinstalling SteamVR
  • Unplugging the HMD and plugging it into another USB port
  • Rebooting
  • Creating a blank UE project in UE 4.18
  • Creating a blank UE project in UE 4.25
  • Reinstalling Unreal Engine
  • Creating a fresh copy of the Experience_Unreal sample in UE 4.18
  • Unplugging the base stations and re-running the samples (to disable head tracking)
  • ...

I am now running out of ideas. Using SteamVR to test the cameras never worked for me and allways shows a "Communication Error". This, however, also has been the case when it worked before. I also can't tell what should have changed to cause this problem in the first place.

I have also attached my SR_logs directory. Hope you can help, searching for a solution.

 

Thanks in advance,
Carsten.

screenshot.jpg

SR_logs.zip

@Daniel_Y, @Marios Bikos

Share this post


Link to post
Share on other sites
Posted (edited)

Also, when I try to run the C sample, the following call returns a failure (code -1).

ViveSR_InitialModule(ID_PASSTHROUGH);

All cleanup calls afterwards return error 1021 (INVALID_CHANGE). I am on the latest SRWorks 0.9.3.0 version. My SteamVR version is 1.12.5. 

Also the normal system see-through of the HMD is working (i.e. when I double-tab the system button on the controller). The cameras aren't broken - it must be some sort of communication error.

Edited by cru89

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...