Jump to content
 
Doozer

Cannot get Cosmos Elite headset to work at all

Recommended Posts

I have spent the last 3 days trying to get my new Cosmos Elite setup to work and am at my wits' end. Base stations are set up, controllers are powered up, but the headset just has the red light glowing on the side. Does the button below the light actually do anything?
Yesterday the headset, controllers and base stations icons all showed in Steam VR (though headset wasn't working). I successfully updated the firmware on all. But today, nothing shows there, and I get a message saying Headset Display Disconnected (208). I have followed all the instructions I've been able to find online, unplugging, replugging, shutting down Steam & VR, restarting, restarting my PC etc etc. I have tried connecting the headset to different DisplayPorts on my graphics card, and also different USB3 ports. No luck doing anything.
A search for Cosmos error codes says for 208 to update firmware, but that was done yesterday, and I can't do it again as the components don't show in Steam VR.
Yesterday I got a message saying Steam VR had detected my headset running as a monitor (and in fact a couple of times my PC screen showed two big "eyes" like the inside of the headset rather than my desktop). I switched to direct display mode, but the headset still refuses to work.
I have generated a System Report (attached) through Steam VR, and it shows the USB as generic (apparently branded USB ports can cause problems).
Currently I seem to be stuck with an $1800 paperweight...

PC Details:
Dell XPS 8930
Core i7-8700
16gb ram
GTX-1060 6gb
Win 10 Pro

SteamVR-2020-05-25-PM_04_49_38.txt

Share this post


Link to post
Share on other sites

Can you confirm you both your monitor and VR are all connected to this one of these slots? 

image.png.e265ede2132d822a0a9bcd19cc42d932.png

Share this post


Link to post
Share on other sites

Yes definitely the port in the graphics card, like the two directly above the white DVI connector in your pic.

Share this post


Link to post
Share on other sites

Do you mind submit 1 issue report and throw me the trace number after?

Share this post


Link to post
Share on other sites

Hi CT, have sent through a support request. The trace number is:  20200525213742

Share this post


Link to post
Share on other sites
4 hours ago, Doozer said:

Hi CT, have sent through a support request. The trace number is:  20200525213742

Can you update NV driver, then restart the PC to try it again?

Share this post


Link to post
Share on other sites

OK, I'm going to have to get on to Dell support for that.  For some reason my system won;t install a new video driver.  I have downloaded new drivers from both Nvidia and Dell, but they all fail on installation - been that way for some time.  I will lodge a support request with Dell, and get back to you as soon as that's sorted. Thx.

Share this post


Link to post
Share on other sites
3 minutes ago, Doozer said:

OK, I'm going to have to get on to Dell support for that.  For some reason my system won;t install a new video driver.  I have downloaded new drivers from both Nvidia and Dell, but they all fail on installation - been that way for some time.  I will lodge a support request with Dell, and get back to you as soon as that's sorted. Thx.

Thanks, let me know how it goes after GPU driver update.

Share this post


Link to post
Share on other sites

sry to impose but how long have u had that PC?? and if not that long, then id suggest do a complete reformat of ur puter and freshly install win 10 and be particular bout wat gets installed bk on the puter, ive had to do that to my cosmos not due to ur prob but had things alrdy on puter before hand that was causing background probs and had to reformat not long ago, its worth a shot tho

Share this post


Link to post
Share on other sites

Honestly, most of the issue could be fixed by clean install your pc and install those latest driver/software from your motherboard support website. And make sure you do window update on all window 10 updates. And go to Nvidia or AMD driver to download the latest driver. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...