Jump to content
 
Sign in to follow this  
synok

Hand Tracking in Unreal Engine 4

Recommended Posts

Posted (edited)

Hello!

I am new to the forum, and wanted to implement hand tracking in my Unreal Engine 4 experiments. I followed the setup and usage guide on the wiki, but had to do a slight change in order to get hand tracking to compile correctly. And that is simply to change the target in "HandApart.Target.cs" and "HandApartEditor.Target.cs" to V1.

Anyways, it compiled correctly and I started UE4. So the hand tracking map was not available. All sample resources had to be copied over to my project since UE cant simply import .uasset files. That is fine. I fired up the sample map after that and tracking works! Great, but I cant seem to build lighting in the sample scene (Swarm agent didnt seem to start and I could not find UnrealLightmass in the code). So I decided to make a new map where I could successfully build lighting in my scene and just add the hand tracking functionalty to it. So at the documentation it says "If you want to use plugin in your existing or new level, just drag HandTrackingProvider actor into the map editor. Remember to replace Editor startup map with your own map". So I added the "HandTrackingProvider" from the copied samples, but it didnt seem to work. So I added "Rigged Hand" to the scene as well, just as in the sample, and this triggered a crash in Unreal. I tried different ways but everytime I add the rigged hands, Unreal Engine seems to crash. Not sure what I am doing wrong here.

Thanks for any help.

Edited by synok

Share this post


Link to post
Share on other sites

Hi, Synok.

Can you show me  what actors you put in your new level?  I need more details to help you out.  You can reply me with a screenshot of WorldOutliner.

According to your description,  I would suggest you check something as followings:

1.Make sure there is a Playerstart or ViveHandTrackingPawn in your level.

2.Check if your GameMode has been changed to ViveHandTrackingMode.

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hello and thanks for your response.

 settings.png
 screen.png

This is tested with the previous 0.9.1 SDK. I will try get into 0.9.2 and see what happens.

Edited by synok

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...