Jump to content
 
edu616

Problems With Vive Cosmos

Recommended Posts

I have had this Cosmos for about a week now. I have an overclocked RTX 2080S paired with a Ryzen 3700X and 16GB of 3600MHz ram. Here are some of the things I have encountered:

  1. SteamVR Motion Smoothing or Reprojection does not work with this headset, so if you have any dropped frames below 90 it will reproject without smoothing and it feels bad.
  2. I have random stutters even in games that are running well below 11.1ms of the 90Hz (please see pictures on link below for graphs). I have no idea what to do as it breaks the immersion pretty badly (and I have tried all I can, nothing seems to make a difference even sub sampling). The example of the link is while just waiting on the dark room (even without opening a game), the rest of the pictures are from playing Boneworks (other games have the same problem anyway).
  3. https://imgur.com/a/3aU6xpx

Can anyone help with this? Thanks!

Share this post


Link to post
Share on other sites

hi, @edu616

are you having the same problems without overclocking?

 

Share this post


Link to post
Share on other sites

There should be no render error. Instead of seeking for "motion smoothing" you should find out why you got those error spike lines.

And I bet NRip got it right - it's probably due to your overclocking, if not hardware issue.

Share this post


Link to post
Share on other sites
6 hours ago, NRip said:

hi, @edu616

are you having the same problems without overclocking?

 

Yes I tried factory settings, plus closing overclocking software. Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, lamyipming said:

There should be no render error. Instead of seeking for "motion smoothing" you should find out why you got those error spike lines.

And I bet NRip got it right - it's probably due to your overclocking, if not hardware issue.

I have tried without any overclocking and closed all overclocking software but still have the issue. The thing is I can play any non vr game and do not notice any of the stutters but when I play in vr I have a a lot of spikes that are accounted as frame drops even tho I can see the frames almost locked at 90fps. 

Share this post


Link to post
Share on other sites

Hello I have more pictures regarding this problems from the vive console: https://imgur.com/gallery/rA58nHv   you will see a lot of frames just skipped and a ton of reprojections even tho I was on the steamVR game launcher

I have tried the following with none giving any results:

1) Tried No OC on my GPU = Problem persisted

2) Uninstalled MSI After Burner and Rivia Turner = Problem persisted

3) Uninstalled Hardware_Info = Problem Persisted

4) Tried turning Gsync Off and tried non vr games = non vr games ran very smooth without any hiccups even with gsync off

5) Tried CCleaner to fix  problems and clean registry = Problem persisted 

6) Tried a reset on the headset within the vive console = When everything got installed back problem persisted 

 

I have no Idea what to try anymore. Thanks!

Share this post


Link to post
Share on other sites

Sounds like a setting in Nividia CP.

Do you have VRSS on or pre-rendered frames set to more than 1 in Nvidia control panel 3D  settings?

Maybe reset everything to default settings you or a program might and tweaked some setting in the control panel

Fink.

Share this post


Link to post
Share on other sites
3 hours ago, Fink said:

Sounds like a setting in Nividia CP.

Do you have VRSS on or pre-rendered frames set to more than 1 in Nvidia control panel 3D  settings?

Maybe reset everything to default settings you or a program might and tweaked some setting in the control panel

Fink.

I think I have found the problem. It was SteamVR beta. I tried before with DDU Uninstaller for drivers and still had the problem so the last thing I needed to try was to go back and instead of beta went into regular and that fixed I still have some frame drops but it's  much much better a lot less fps drops. I still have a lot of reprojections but at least it felt better without all the frame drops. 

  • Like 3

Share this post


Link to post
Share on other sites
3 hours ago, edu616 said:

I think I have found the problem. It was SteamVR beta. I tried before with DDU Uninstaller for drivers and still had the problem so the last thing I needed to try was to go back and instead of beta went into regular and that fixed I still have some frame drops but it's  much much better a lot less fps drops. I still have a lot of reprojections but at least it felt better without all the frame drops. 

Have you tried to turn off/re-enable SMT on AMD?

I'm not sure it will work or not, just giving you a suggestion imho.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...