Jump to content
 
llealloo

Cosmos Elite HMD + Wireless accelerometer jitter

Recommended Posts

I just got my Cosmos Elite setup with the Wireless Adapter. It is tracking and everything is connected and software is updated... but it seems EXTREMELY sensitive to any kind of accelerometer motion. For example when I am in VRChat looking at a mirror and I tap my foot on the ground (not enough to move my head or the headset really at all) my avatar is bouncing up and down like there's a jackhammer hitting my face- and it looks like it from within the HMD as well. It is making me motion sick because this same effect happens whenever I turn my head, walk, or do any sudden motion which is pretty much every time you move in VR.

At first I thought it was lag, but it's not. If I squash/clasp the HMD ridiculously tightly to my face, the jitters almost completely disappear and there seems to be virtually no lag that I can tell? When wearing it normally (and I assure you I have fitted it properly and as tightly as possible), the headset itself is not bouncing around on my face much but SteamVR is seeing it jagging and jittering all over the place any time I move.

Is this a known issue? Is there some kind of compensatory accelerometer setting buried in the firmware that can be adjusted, I hope? I really hope so. Thank you

 

@stvnxu

Share this post


Link to post
Share on other sites

Looks like these things do have accelerometers. Hallelujah

Now if I can find out how to turn down the sensitivity / calibrate them. Coming up empty handed though. This seems like a firmware issue.

Also I am using Valve 2.0 Base Stations, but this really seems like Cosmos Elite HMD firmware issue because the Valve Index HMD tracks flawlessly on my setup.

Share this post


Link to post
Share on other sites

@llealloo I've never had this happen with my original Cosmos with wireless.  Maybe check that your base stations are firmly mounted above head level and you do not have any reflective surfaces in your play area.  I know my Vive Pro w/base stations can get a bit jittery if either are the case.  Also check that your wireless sensor is firmly mounted above head level.  Do you still use the stock faceplate pads?

  • Like 1

Share this post


Link to post
Share on other sites

Base stations are set up properly. I know bc my Index HMD is flawless, super buttery, perfect tracking.

Faceplate pads might make a difference, and I'd be down to try those anyway. Do you have a recommendation for non-stock pads?

Still wanna hear back from tech staff on the accelerometer (if there is a way to calibrate it)

Share this post


Link to post
Share on other sites
14 minutes ago, llealloo said:

Base stations are set up properly. I know bc my Index HMD is flawless, super buttery, perfect tracking.

Faceplate pads might make a difference, and I'd be down to try those anyway. Do you have a recommendation for non-stock pads?

Still wanna hear back from tech staff on the accelerometer (if there is a way to calibrate it)

No I still use stock faceplate pads.  I just thought that if you changed these it might make a bit too loose and wobbly.  Sorry I don't know of any settings that would help.  You are probably best to contact Vive Support and see if they can help.  Good luck mate.

Share this post


Link to post
Share on other sites
Posted (edited)

@llealloo

I've tried Cosmos Elite mounted on Wireless kit today and never had this case like yours.

Sharing your ingame and real-time videos here might help others and Vive support team clarify your issue. 

Edited by w.y

Share this post


Link to post
Share on other sites

That's great to hear! That makes me think it can be fixed.
Thanks for your input!
I'm goin to see if I can find some improvements by somehow fitting it differently.

@C.T. @stvnxu

Share this post


Link to post
Share on other sites

Hi @llealloo,

Thanks for sharing here and apologies on the issue you're experiencing! To my understanding, there is no setting available to users in calibrating the accelerometer. As @w.y shared, we couldn't reproduce it on our end. But don't fret, we're here to help!

Let's start by first collecting more information to identify all the variables. 

  • Could you record and share a clip of the issue you're describing? 
  • Please provide me your PC specs that you're using to run the Cosmos Elite + wireless.
  • Are you experiencing this accelerometer jitter in all your other VR experiences? including your SteamVR home? 
  • Could you try using the Cosmos Elite wired and see if you're still experiencing the same issue? 

Steve

Share this post


Link to post
Share on other sites

Hi @stvnxu always with the very nice responses, thank you for that!

I am happy to report that after a number of restarts, setup changes, and configuration changes back and forth between the Cosmos and Index HMD the issue somewhere along those lines resolved. The whole system is working rather flawlessly, as expected.

That initial period of accelerometer hyperactivity was rather strange, no idea if it was a hardware break in period or some kind of software calibration issue. Thankfully it is not happening anymore. If it happens again I will try to somehow capture in a video. My PC / setup specs are: 9900k + Vega64. Using Index controllers and base stations.

Just played a nice long bit with this setup and I am in love. Being untethered is utterly fantastic. Thank you

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...