Jump to content
 
yann

Cosmos : Start gesture detection failed : Camera

Recommended Posts

Hello,

I'm trying to use hand tracking in Unity with a Cosmos but at the start if the sample scene i have the "Start gesture detection failed: Camera" error message.

I'm using the 0.9.0 HandTraking SDK in Unity 5.6.5 (can't update Unity). SteamVR is updated to it's last beta version and all my drivers too. Vive console version is 1.0.9.6.

The headset is working fine on it's own.

Does someone have an idea ?

 

Thanks 🙂

@zzy

Share this post


Link to post
Share on other sites

Hi @yann

We are aware of this problem. This is due to Vive console v1.0.9.x has changed the API for camera and breaking the hand tracking SDK.

We plan to release new version (v0.9.1) by the end of this month, which should have fix for the problem. In the mean time, you can check if it's possible to downgrade Vive Console to version v1.0.8.8 which should work with hand tracking sdk v0.9.0.

Share this post


Link to post
Share on other sites

Thanks for you reply.

Do you know where i can download it ? i can't find it and i can't wait for your version at the end of the month...

Share this post


Link to post
Share on other sites

Hi @yann

I confirmed again about the Vive console, hand tracking sdk v0.9.0 works fine on our test machine with Vive console v1.0.10.4 beta, so maybe I was wrong about the API bug in previous post.

Please make sure following requirements before start hand tracking:

  1. Cosmos HMD is in ready status. Avoid sleeping, or not tracking status.
  2. Put on your Cosmos HMD

If you still meet the same problem, can you provide some logs about your failure? You can delete existing logs and run again for more clear logs. Just make sure to close application and vive console when you delete/copy the logs.

  1. Hand tracking  SDK log: %APPDATA%\..\Local\Aristo\Aristo.log
  2. Cosmos runtime log: C:\ProgramData\HTC\ViveSoftware\ViveVRRuntime\logs

Share this post


Link to post
Share on other sites

I tried updating vive console to v1.0.10.4beta but i still have the same error.

the most revelant things i found came from the HTC logs :

Quote


[2020-02-10 12:06:14.459 +1 0x49E4 INFO -vive_eyes] [INFO][HtcCameraComponent]IsVideoStreamActive return m_bIsVideoStreamActive:0 bPaused:0, flElapsedTime:0.000000

[2020-02-10 12:06:14.459 +1 0x49E4 INFO Camera] [0] StartVideoStream, bActive=0 bPaused=0 flElapsedTime=0.000000
[2020-02-10 12:06:14.459 +1 0x49E4 INFO -vive_eyes] [INFO][HtcCameraComponent]GetCameraFrameBufferingRequirements return bRet:1 queuesize:4 datasize:921824

[2020-02-10 12:06:14.459 +1 0x49E4 INFO -vive_eyes] [INFO]STCamAPI: cmd:3 argc:4

[2020-02-10 12:06:14.459 +1 0x49E4 INFO -vive_eyes] [INFO][CamAPI] cmd = 3

[2020-02-10 12:06:14.459 +1 0x49E4 INFO -vive_eyes] [INFO]STCamAPI: cmd:6 argc:1

[2020-02-10 12:06:14.459 +1 0x49E4 INFO -vive_eyes] [INFO][CamAPI] cmd = 6

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO][HtcCameraComponent]SetCameraFrameBuffering return bRet:1 nFrameBufferCount:4 nFrameBufferDataSize:921824

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO][HtcCameraComponent]SetCameraVideoSinkCallback return bRet:1

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO][HtcCameraComponent]GetCameraVideoStreamFormat return m_nVideoStreamFormat:2

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO]STCamAPI: cmd:6 argc:1

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO][CamAPI] cmd = 6

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO]STCamAPI: cmd:1 argc:1

[2020-02-10 12:06:14.460 +1 0x49E4 INFO -vive_eyes] [INFO][CamAPI] cmd = 1

[2020-02-10 12:06:14.462 +1 0x49E4 INFO -vive_eyes] [INFO][Camera_init]

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [WARNING]SETUP: Couldn't find preview pin using SmartTee

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format RGB24 @ 640 by 962

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format RGB32 @ 640 by 962

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format RGB555 @ 640 by 962

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format RGB565 @ 640 by 962

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format YUY2 @ 640 by 962

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format YVYU @ 640 by 962

[2020-02-10 12:06:14.532 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format YUYV @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format IYUV @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format UYVY @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format NV12 @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format YVU9 @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format Y411 @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format Y41P @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format Y211 @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format AYUV @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format Y800 @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format Y8 @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format GREY @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [INFO][videoInput::start]SETUP: trying format OTHER @ 640 by 962

[2020-02-10 12:06:14.533 +1 0x49E4 INFO -vive_eyes] [ERROR]SETUP: couldn't find requested size - searching for closest matching size

[2020-02-10 12:06:14.737 +1 0x49E4 INFO -vive_eyes] [INFO][init_edge_reduction] Puplish edge reduction enable: 1

[2020-02-10 12:06:14.737 +1 0x49E4 INFO -vive_eyes] [INFO][gamma_correction] Gamma Correction enable: 1

[2020-02-10 12:06:14.737 +1 0x49E4 INFO -vive_eyes] [INFO][gamma_correction] gamma_l = 1.000000, gamma_h = 0.700000

[2020-02-10 12:06:14.737 +1 0x49E4 INFO -vive_eyes] [ERROR][Camera_init] Set Up Fail! camera ID 0, streaming 1

[2020-02-10 12:06:14.738 +1 0x49E4 INFO -vive_eyes] [ERROR][CamAPI][CAM_CMD_STREAMONOFF] Camera_init FAILED.

[2020-02-10 12:06:14.738 +1 0x49E4 INFO -vive_eyes] [INFO]STCamAPI: cmd:8 argc:1

[2020-02-10 12:06:14.738 +1 0x49E4 INFO -vive_eyes] [INFO][CamAPI] cmd = 8

[2020-02-10 12:06:14.738 +1 0x49E4 INFO -vive_eyes] [WARNING][onHmdErrorUpdated] Update error, errString: HMDCAMERR{c0}

[2020-02-10 12:06:14.738 +1 0x49E4 ERROR EventManager] Push internal error 201 : HMDCAMERR{c0}
[2020-02-10 12:06:14.738 +1 0x49E4 INFO -vive_eyes] [INFO][HtcCameraComponent]StartVideoStream m_StartStreamTimeInSecond:68.270298, IsVideoStreamActive = 0, isSetup = 0

[2020-02-10 12:06:14.738 +1 0x49E4 ERROR Camera] StartVideoStream failed

Did you make your tests with a Cosmos ?
See full log attached, it's not "cleaned logs" the last try was with Vive console v1.0.10.4beta, the other are with v1.0.9.6

vrserver_20200210.txt Aristo.log

Share this post


Link to post
Share on other sites

Hi @yann,

From the log, it seems that the camera is currently being used by another app, and therefore Vive Console cannot start the camera.

Please help to check the following items:

  1. Is there any error displayed in Vive Console? Please also check the camera tab in settings.
  2. Please help to identify if there are any other apps that is using camera. Please try to close all unrelevant apps or restart your PC to see if it helps.
  3. Please help to check if the camera see through function is working correctly. Double press the Vive button of your right controller to enable/disable see through. You should be to see your environment if success.

Share this post


Link to post
Share on other sites

Hi @zzy

Here some check :

  1. No error in the Vive Console. The camera in the Camera tab is enabled (see real surronding check, press button twice to see surrounding check and 60Hz pouwer supply frequency). Interesting point : SteamVR does not have a Camera tab is it normal ?
  2. I've restarted my computer and close all other apps but nothing changed still the same error. Interesting point : The camera app from windows can acces the camera. It's a weird image but still it's not blocked.
  3. The see through function is not working properly. When i activate it my view in VR (in the steamVR app) is black and blinking weirdly. I've made a support mail to Vive about that and i'm still waiting for an answer.

 

Share this post


Link to post
Share on other sites

Hi @yann,

Cosmos camera is not visible in SteamVR, so your settings looks correct. If see through function is not working, then hand tracking sdk cannot get the camera frame to detect hand. Hope the support mail can help to solve this problem.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...