Jump to content
 
Daverp

Issues installing

Recommended Posts

Hi I've had my cosmos since yesterday and haven't been able to use it as every time I try to install everything it tells me that it can't detect the usb. I have tried 3 different usb ports and I'm still getting the same problem. Has anyone managed to get past this issue as it is ridiculous that a £599 piece of kit that anyone can buy is basically useless straight away 

 

Share this post


Link to post
Share on other sites

If you can, try testing with different cables to confirm it's not a cable issue (check for loose connections) Are you using USB 3 ports?

Share this post


Link to post
Share on other sites

Make sure you switched the usb link on (the small blue button on the front.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/1/2020 at 10:55 AM, Daverp said:

Hi I've had my cosmos since yesterday and haven't been able to use it as every time I try to install everything it tells me that it can't detect the usb. I have tried 3 different usb ports and I'm still getting the same problem. Has anyone managed to get past this issue as it is ridiculous that a £599 piece of kit that anyone can buy is basically useless straight away 

 

@Daverp - Just checking in if you were able to resolve your issue yet with the suggested solutions above? The usb link that A-Jey is referring to is called a link box. It's the little box that connects between your Cosmos headset and desktop/laptop. A green light indicator means it is on which you'll need for it to work successfully during installation.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...