Jump to content
 
marskod

Unable to apply VIU action set

Recommended Posts

Hi,

I recently installed VIU v1.10.7, and I am using it alongside steamvr 2.5.0 . I am trying to apply the VIU action set but it will not work. When clicking "use recommended (true)", it will open up the binding menu, but this screen stays the same:
image.png.3a56b92cec488e896be63c936cf4ca7d.png

When using VIU v1.10.3, if i click "use recommended", everything works, but it does not work with v1.10.7. Ive tried completely removing steamvr, steamvr_input, VIU, and doing a fresh install, and it still doesnt work.

I am unable to receive input from any devices with this version. Please let me know how I can fix this.

I am using Unity 2019.1.5f just FYI

@chengnay @Dario

Share this post


Link to post
Share on other sites

Make sure you can see the popup dialog that asks you save and generate the actions

Share this post


Link to post
Share on other sites

Yes, I can see the popup for generating the actions. Whenever we generate it, the VIU popup that says "Apply VIU Action set" doesn't go away, meaning it didn't actually properly apply the VIU action set. This works as expected on VIU 1.10.3, but not any version after that. We've found a workaround for the issue, but we'd like to get the root cause of the problem. 

@Dario @chengnay

Share this post


Link to post
Share on other sites

Are you also seeing a similar issue with the SteamVR settings popup? Sounds like a file permissions issue -  can you share your workaround to help others who may be having  a similar issue?

 

 

Share this post


Link to post
Share on other sites

The issue is that it's not generating the right bindings for the "vive tracker held in hand". When I look at the binding page for the trackers, the htc input binding page is present, but there are no actual bindings. The way I fixed this was copying over the bindings from v1.10.3 and replacing the empty bindings generated by v1.10.7. This fixed the problem, but I imagine I will run into this issue again with future upgrades. 

@Dario @chengnay

Share this post


Link to post
Share on other sites

@marskod I just tested new project with VIU v1.10.7 + SteamVR Plugin 2.5.0 + Unity 2019.1.5f1 and everything works fine.

Did you upgrade your project from VIU v1.10.3 to v1.10.7?

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...