Jump to content
 
MetalistBat

Headphones and Microphone doesn't work

Recommended Posts

@stvnxu I fixed it but i cant tell if it was the Firmware Update that i did tiday or me putting the Headset into a different USB 3 Port (I feel so dump for not trying this earlier).  

Maybe this will help you guys as well @MetalistBat & @ypbrevar

  • Like 1

Share this post


Link to post
Share on other sites

@MetalistBat - If you're testing finds that the microphone isn't working, go ahead and submit an d issue report so I can try to get ahead of it in resolving this. Thanks for your patience thus far.

Share this post


Link to post
Share on other sites

@xPriime - Ah all good. I'm glad all is resolved and you got it up and running. 🙂  

Share this post


Link to post
Share on other sites
Posted (edited)

I had this issue and switched the USB for the link box from a red outlet (USB 3.1 Gen 2) to the normal blue (USB 3.1 Gen 1), and then the mic showed up both in Device Manager and in Sound options, no restart etc needed.

Edited by Risby
  • Like 1

Share this post


Link to post
Share on other sites

I have the same issue where my microphone disappears from recording devices as soon as any noise is detected. Earphones work great its just the microphone cuts out for any online multiplayer game. I've tried every USB port on my PC and have restarted and deleted/reinstalled everything twice. I already have a Ticket: 50137865.

@C.T. @stvnxu

Share this post


Link to post
Share on other sites
On 4/8/2020 at 6:04 AM, TheKingleofDingle said:

I have the same issue where my microphone disappears from recording devices as soon as any noise is detected. Earphones work great its just the microphone cuts out for any online multiplayer game. I've tried every USB port on my PC and have restarted and deleted/reinstalled everything twice. I already have a Ticket: 50137865.

@C.T. @stvnxu

Do you mind sending me DXDiag report via PM? 

Share this post


Link to post
Share on other sites
6 hours ago, MetalistBat said:

Still not working.

Can you check if your USB driver has been updated? I can PM you the link if you need it.

Share this post


Link to post
Share on other sites

I have the cosmos elite and headphones work great just the microphone isn't detected at all. couldnt connect usb to any other ports but this one in the back since all kept not working. help? Not sure what to do just found out its been using my webcam mic. @C.T.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...