Jump to content
 
Beta_Tester

Focus Plus - Viveport Streaming

Recommended Posts

Been trying out the Viveport streaming recently which is brilliant. 

One thing I have noticed is that (if SteVR isn't already running) the headset/Viveport Desktop don't wait long enough for SteamVR to start on the PC, causing a connection error. If StreamVR is already running it is fine.

Just a minor issue though, and this seems like a great new feature.

Share this post


Link to post
Share on other sites

@Beta_Tester Glad you're enjoying it! There are definitely some major limitations we're attempting to overcome with both WiFi and the 835 platform with this deployment.

Where do you see the connection error and what text do you see? You're saying that if you're booting SteamVR from a cold start, there isn't enough of a delay window for the compositor to boot up and establish the pipe to the content? I can feedback this directly to the team who built out this feature if you provide a clear enough report for them to action on. Does it happen across all content or just "heavy" content? What's your system? Are you loading off an SSD or a standard slow disk?

Cheers!

Share this post


Link to post
Share on other sites
Posted (edited)

@VibrantNebula Yes, there doesn't appear to be enough of a delay & it happens to all content (when Steam VR isn't running).

SteamVR, Viveport & most apps are on HDD. OS (and therefore rrServer) are on SSD. AMD Ryzen 2700X with 1070Ti & 16gb ram. PC doesn't struggle at all once things are running.

I'll dig out the error tomorrow.

Edited by Beta_Tester

Share this post


Link to post
Share on other sites

@VibrantNebula Just noticed another issue which appears to have started since the latest VIVEPORT update (1.3.13 r8). I have to now manually click the "Check PC" option to start the Vive-RRServer.exe process. This is after every time VIVEPORT is shutdown or the PC is restarted.

Can log with support if you think that is best.

Share this post


Link to post
Share on other sites

@VibrantNebula or anyone else able to assist? I've logged a case with Vive support (for the issue with the RR server), but wanted to know whether I need to log the issue with support about the error displayed if SteamVR doesn't start in time?!?!?

Share this post


Link to post
Share on other sites

@Beta_Tester I've alerted that specific product team of your report and am awaiting feedback from them. Please bear in mind this is a beta-feature and so support is very case by case as early feedback comes in and we learn about potential issues people are encountering. They have the URL to this thread so they'll be able to see whatever you post here - they may not have direct access to the ticketing system that report issue feature feeds data into. That said, that report issue feature definitely still has a place as it collects and uploads logs. I'll report back here as soon as I hear any feedback from them.

  • Like 1

Share this post


Link to post
Share on other sites

@VibrantNebulaThanks for all your help with this. I've had Guile Chao from Vive support pick this up, who has been liaising with the product team. Hopefully will be fixed shortly.

Share this post


Link to post
Share on other sites
On 1/17/2020 at 12:38 AM, Beta_Tester said:

@VibrantNebulaThanks for all your help with this. I've had Guile Chao from Vive support pick this up, who has been liaising with the product team. Hopefully will be fixed shortly.

Looks like this timing issue will be fixed in an upcoming VivePort release, so thanks to HTC for being so responsive and quick.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@VibrantNebula Just wanted to let you know that the latest Viveport and headset updates have completely eliminated my issues. The streaming function is really good now, I'm finding very little jitter & almost all apps & games are working with no issues.

Many thanks to the devs who have worked on this. So much better than the supposed "wireless" option from Oculus! 😉

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...