Jump to content

Temporarily Disabling Chaperone or Collision Boundary


Recommended Posts

I wanted to try your fix because chaperone is really bothering me when looking at movies but I dont have ViveVRRuntime. I tried both path, searched for its name on PC and I dont have it? My HTC is having detection problems so I migth lack something? How do I get it?

Link to post
Share on other sites
  • Replies 21
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@lamyipming - For transparencies sake, I'm comfortable sharing that the bulk of the Cosmo team's engineering resources are currently focused on tracking. Features and other UX tweaks will have higher

This warms my heart actually, knowing that tracking issue are currently the #1 priority. I can overlook the chaperone annoyances knowing this. In any case, I have the same problem with Elite Danger

That's actually very nice to hear! Makes me feel very warm inside - knowing that you care! I was kinda scared because I watched the youtube video with the new lighthouse kit for Cosmos that will be re

16 hours ago, Squible said:

I wanted to try your fix because chaperone is really bothering me when looking at movies but I dont have ViveVRRuntime. I tried both path, searched for its name on PC and I dont have it? My HTC is having detection problems so I migth lack something? How do I get it?

I guess the actual path might vary for difference people, so I can't tell where it is in your PC.

The way I found mine is to use a software called Sandboxie. I used Sandboxie to launch VIVE Console, adjust the chaperone settings in Lens, and close the VR. It will crash for some reasons, but Sandboxie can log what files have been modified by Vive Console in the independent environment. Find the correct text file location and there you can change the alpha from 15 to 0.

Or let's hope Vive will fix this soon.

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 1 month later...

I joined to say a huge thanks for sharing this. The boundary circle at my feet was driving me nuts in games and I searched everywhere to disable it. Even on its lowest transparency setting it was still very distracting.

Your simple fix completely eliminated the circle. I have to wonder why don’t HTC just provide a simple toggle to turn it on/off in settings...

Anyway. Thank you so much. Half Life Alyx is so much fun to play now without that circle!

Link to post
Share on other sites
On 12/9/2019 at 4:13 PM, lamyipming said:

Today I found a fix. Hope this helps anyone who faces the same problem. 

First terminate Vive Console and Viveport. Then use notepad to open the settings file "htcvr.vrsettings" located in "C:\ProgramData\HTC\ViveSoftware\ViveVRRuntime". There you can see that even if you have dragged the transparency all the way to 0 in the Lens menu, the "CollisionBoundsColorGammaA" is still set to 15. I think that this is a bug of the Lens software. Somehow they set the minimum value of the dragging bar to 15, instead of 0. Manually changing the "CollisionBoundsColorGammaA" to 0 will disable the boundary completely. (You will need to save the file with admin right.)

 

You da man! It's finally gone from my face!

Link to post
Share on other sites
  • 1 month later...

I mean, it feels really terrible to raise this issue literally more than half a year ago, found the exact problem causing it, posted the solution online, and HTC is still not fixing it despite how small and easy fix it should be. It should only take your developers like 1 minute to resolve this issue - just set the damn minimum value to 0 instead of 15. How hard could it be?

 

I've been patience to defend this product numerous times and hoping the tracking to get improved some day. But honestly this chaperone transparency issue disappoints me very, very much. Seems like this will never be fixed. Seems like HTC doesn't care.

 

I just want to enjoy a movie without re-running the whole room setup to change to seated position. 

  • Like 1
Link to post
Share on other sites
  • 3 months later...

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...