Jump to content
 
Randonlag

Error Code 215 During Setup, But Drivers ARE Updated

Recommended Posts

Got the Cosmos today and arrived at the same error.

My setup: Ryzen 5 2600X, mobo ASUS Prime B450-PLUS, KFA2 GTX 1070 EX (on first PICe), Sapphire HD7950 Boost (on second PCIe). I'm using an HDMI switch to use one or another GPU, using the 1070 for this VR setup.  SteamVR installed on F drive, HTC software on E drive. Drivers and BIOS are the latest available.

Tried to follow all this SteamVR instructions, no luck.

Share this post


Link to post
Share on other sites

After multiple attempts (btw about my hw setup using a Corsair TXM 750 W 80+ Gold PSU, using only one GPU at time is more than enough):

  • Tied rebooting multiple times the console, changing USB to many other different ports on the back and front of the PC, power cycling the Link box, enabling Direct Mode, restarting the PC, restarting SteamVR.
  • Tried using latest beta 1.0.9.6 and updating headset and controllers firmware.
  • Tried reinstalling all HTC software, uninstall and reinstall Steam and SteamVR.
  • Tried switching to the second AMD GPU instead of using the Nvidia

The SteamVR app state always no headset detected, error 108.

Switching GPU there is a difference: on Nvidia the power light on the headset is red and the Console give me an 215 error, on AMD the led is green and the Console give me an 210 error. Both GPU use the latest drivers 441.87 for Nvidia and Adrenalin 19.12.2 for the AMD.

Submitted an issue report Trace No 20200113132906

@C.T.

Share this post


Link to post
Share on other sites
  • Uninstalled ASUS AI Suite that seems to create problems with SteamVR
  • Fixed SteamVR installation path using vrpathreg (since not installed on drive C)
  • Updated to latest mobo bios 2008 release
  • Performed a settings reset from console

No difference. After the bios update the console briefly flash a 003 error (no DP link) before settling to the same 215 error. After settings reset didn't show the message again.

Share this post


Link to post
Share on other sites

@davide445

Thanks for all the details! Super helpful. Just double checking, are you using a DP or mini DP cable to connect your linkbox to your graphics card? 

Steve

Share this post


Link to post
Share on other sites
1 hour ago, davide445 said:

Standard DisplayPort

Hey Davide,

2 things:

1. Can you try all the original cabling? Without using any adapters whatsoever.

2. Can you try removing one GPU or disabling it in device manager and seeing if it works?

Thanks!

/shen

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, Shen Ye said:

1. Can you try all the original cabling? Without using any adapters whatsoever.

I'm not using any adapter, just what available in the HTC Cosmos box. 

Will try tomorrow with just one GPU. 

Share this post


Link to post
Share on other sites
4 hours ago, davide445 said:

I'm not using any adapter, just what available in the HTC Cosmos box. 

Will try tomorrow with just one GPU. 

Great. If it doesn't work, please do a bug report via the troubleshooting section of the Vive Console, and DM me a trace number. We can use it to check the logs.

We will try our best to get it working for you.

Fwiw, I have a 2080 and Vega 64 in the same machine, and it works fine, so we should be able to figure it out.

@Synthesis

Share this post


Link to post
Share on other sites

Tested removing the AMD card on the second PCIe slot and now all is working.

I use the second card only on Linux (the Nvidia card used for compute while using the second card for driving the display so to free max compute resources), so will be better to have both installed.

Edited by davide445
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...