Jump to content
 
docb

Having an issue installing as a plugin in UE4

Recommended Posts

Hand Tracking Version: 0.8.2

Unreal Engine 4 Version: 4.23

Windows 10

Extracted the hand tracking zip, moved to the Unreal Engine/Source/ThirdParty folder.  First, get "Missing VRHands Modules" with the message "The following modules are missing or build with a different engine version: ViveHandTracking - Would you like to rebuild them now?" Select "Yes".  Starts build.  Error: VRHands could not be compiled.  Try rebuilding from source manually.

My only option is "OK".  Is there a way to get rebuild from source manually?  How can I get this to work with Unreal?  Thanks!

 

Share this post


Link to post
Share on other sites

Hi @docb

You need to regenerate VS project and rebuild from source, please follow the steps below:

  1. Delete immediate and saved folders in your project.
  2. Right click your *.uproject file and select "generate source code from project" command
  3. Open your project in VS and rebuild

Share this post


Link to post
Share on other sites

@zzy Thanks for the help!

When I go to the project folder, delete "Intermediate" and "Saved" folders, and then right click and select "Generate Visual Studio project files", I get the error "This project does not have any source code.  You need to add C++ source files to the project from the Editor before you can generate project files".  Since I can't open the project, I can't add C++ files.

When I create a new project, add C++ blueprint, enable plugin, and then follow your instructions, I get the same error after generating the project files and after rebuilding the code in Visual Studio.

When I do the same thing with a new C++ project. Enable plugin, restart UE, see the compile error, follow your instructions, I get the same error after generating the project files and after rebuilding the code in Visual Studio.  Doesn't seem to want to build.

Edited by docb

Share this post


Link to post
Share on other sites

Hi @docb

This seems like your unreal project is blueprint only and does not support c++ files.

You need to add new c++ source files in your project first. Please try the the steps from link1 or link2.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...