Jump to content

Problems with controllers in SteamVR


Recommended Posts

Hi. I have my new Vive Cosmos since 4 days. 

Everything works fine but in several games at Steam VR, when the game starts the controllers change and it appears like the old Vive controllers so I can move it but no button is working.

I can tell you that this issue is in Batman Arkham VR and Skyrim VR but I am sure that this suceed at more games.

Have I to install any driver? What do you think I can do?

A lot thanks!.

Link to post
Share on other sites

Hi @SOFTGUNMAV,

We're sorry about the issue you're currently experiencing. If you find your headset tracking in the game and not your controllers (e.g. they are stuck on the floor), then it's most likely due to controller compatibility. This also applies to your scenario where Cosmos controllers aren't being accurately represented. This means that the developers of the VR title have not directly supported the new Cosmos controllers at the moment. 

We do have one workaround which is using the custom controller bindings provided by the Steam community.

1. SteamVR

2. SteamVR Dashboard (three lines on top left corner)

3. Devices

4. Controller Settings

5. Select game

6. Select Cosmos controller (make sure your cosmos controllers are on)

7. Select Community Binding and apply. 

8. Play

Let me know if this works out!

 

Link to post
Share on other sites
  • 1 year later...
On 12/5/2019 at 3:31 AM, stvnxu said:

Hi @SOFTGUNMAV,

We're sorry about the issue you're currently experiencing. If you find your headset tracking in the game and not your controllers (e.g. they are stuck on the floor), then it's most likely due to controller compatibility. This also applies to your scenario where Cosmos controllers aren't being accurately represented. This means that the developers of the VR title have not directly supported the new Cosmos controllers at the moment. 

We do have one workaround which is using the custom controller bindings provided by the Steam community.

1. SteamVR

2. SteamVR Dashboard (three lines on top left corner)

3. Devices

4. Controller Settings

5. Select game

6. Select Cosmos controller (make sure your cosmos controllers are on)

7. Select Community Binding and apply. 

8. Play

Let me know if this works out!

 

The steps don't work. I can go into the controller bindings and change them but as soon as I go into the game they dont work and when I go through the steam VR menu while in game to change them it just constantly loads. Really tempted to refund the game :(

Link to post
Share on other sites

@LuigiNumber1 - Which game? Per Skyrim/FO4, Bethesda games ported into VR are extra finicky because they're using Bethesda's in-house custom game engine (Creation Engine). Because of this, alot of SteamVR systems like controller remapping aren't really supported which means that Bethesda generally has to apply a hard patch to try and support new hardware. Bethesda hasn't published any updates for SkyrimVR since ~April 2018 as far as I can tell which predates the release of Cosmos. Bethesda games have similar issues with Index Controllers for the same reason. It's kind of just a Bethesda thing due to their custom engine.

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...