Jump to content
 
TomCgcmfc

Vive Pro Audio Crackling after initial startup

Recommended Posts

I just bought the Vive Cosmos and I have the exact same problem. Everytime I start up the headset the audio is completely shot(loud static) until I unplug and reset the USB on my link box. any word on a fix??

Share this post


Link to post
Share on other sites

I finally got this sound startup problem solved today!  As I said earlier the problem was that my Vive Pro kept wanting to use the Speakers Vive Pro multimedia option.  This is a USB connection so since I have a fair amount or usb devices I think that bandwidth was the problem.  I needed to restart the headset every time to get this to work ok.  I had tried using the Vive Pro nvidia high definition audio but my sound settings said that this was only a hdmi connection so it would not work properly,

So, today the first thing I did was verify my (non-beta) SteamVR files (from steam library right click/properties/local files tab).   I then reinstalled the nvidia HD drivers (actually used DDU , in Safe mode, to uninstall then reinstalled my current 442.59 drivers, just selecting custom install graphics, hd audio and physx).  

After a PC restart (always a good idea after installing nvidia drivers) I powered on my link box, which of course wanted to startup the speakers vive pro usb.  I then went into win10 sound settings/sound control panel, and disabled these and reselected my desktop speakers (nvidia hi def) on my sound taskbar.  I then started up SteamVR and went to the audio settings and for audio in there was a manual option for Vive Pro Nvidia hi def audio (which I had not seen before) so I selected this.  I just left the audio in (mic) on the headset option.  I restarted the headset and I could see that it then properly showed the nvidia hi def were used and when I tested it with a desktop mp3 music file it played perfectly through my vive pro headphones.

So now I just need to startup my pc (letting steam and viveport apps startup enabled on my task manager startup tab).  Then I power on my link box (which now does not startup the old speakers vive pro usb audio but stays on my desktop speakers.  Then I startup SteamVR (I found this easiest to do by just pressing the button on the left side of my headset) and when StreamVR starts up it properly switches to the vive pro nvidia hi def audio and everything works perfectly.  If I go to the win10 sound settings again I can see that the audio out is to the vive pro nvidia and my mic is through the vive pro multimedia and I can test this on it's sound bar (or mute it with the right headphone mic button).  When I exit SteamVR and then power off my link box my sound gets properly re-directed to my desktop speakers.

I have tried at least 6x cold restarts and so far this is working perfectly.  I also checked my SteamVR settings/audio and now both options are on headset audio in, not manual. Success at last, lol!

Share this post


Link to post
Share on other sites

@TomCgcmfc - You can also pin the SteamVR compositor to the taskbar. I do this on all of my VRPCs to facilitate start up. 

Pressing the button on the headset only works if you have the Vive software installed which results in a task running in the background which listens for that input.

Screenshot (22).png

Share this post


Link to post
Share on other sites
5 hours ago, VibrantNebula said:

@TomCgcmfc - You can also pin the SteamVR compositor to the taskbar. I do this on all of my VRPCs to facilitate start up. 

Pressing the button on the headset only works if you have the Vive software installed which results in a task running in the background which listens for that input.

Screenshot (22).png

 

So you are telling me you do not have Vive software installed?  Am I better to uninstall all Vive software?  Please explain, thanks.

I have both Steam Client Bootstrapper and VivePort Desktop enabled in my win10 startup.  These both show up on my taskbar and are pretty well as easy to use.  Should I disable both of these?

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...