Jump to content
 
MyBug

Eye Calibration Data is ignored in Unity build version.

Recommended Posts

Hi, I'm using VIVE Pro Eye with some medical purposes.

I'm doing well with Unity Editor. Eye Calibration is fine in the editor mode. but when I build it and run, it seems like all eye tracking data is flushed. My tracking direction is fixed to (0, 0, 0), whether I move my eyes or not.

So I tried to run calibration in runtime, within the Start()

    void Start()
    {
        bool calibrationSuccessful = false;
        do
            calibrationSuccessful = SRanipal_Eye_v2.LaunchEyeCalibration();
        while (!calibrationSuccessful);
        
        StartTesting();
    }

like this, which repeats calibration until it finishes with the result of success.

It works fine in the editor version, and also works fine in build version. But in the build version, only the calibration scene is loaded, and the data is whitened again.

Even with the in-game calibration, the eye tracking data is not loaded in build version.

It's so weird that it works perfectly fine in editor version, but not working when I build it.

Is there any suggestions for the problem?

I'm using Unity 2019.2.13f1 version on Windows, and I enclosed a picture of my build settings.

 

(+ Actually It worked fine in build version with the in-game calibration before the "Offset Bug", but after that bug happened, It stopped working suddenly. (Not sure about it))

settings.png

@Corvus, @Jad, @Daniel_Y @zzy

Share this post


Link to post
Share on other sites

@MyBug Are you still experiencing this issue? The calibration offset issue was fixed with a recent version of SteamVR Beta. Can you test again to see if that fixes your problem?

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...