Jump to content

Recommended Posts

got some help on discord. turns out my nose was pushing the lenses, so i tried wearing up higher and it worked for me. hope this helps any of you.

but, Vive, please either let us disable this, or at least make the dialog transparent so we can see through it. A others said, could easily just put the dialog in the dashboard.  

Edited by pixelfairy
grammer
Link to post
Share on other sites
  • 4 months later...
On 1/19/2021 at 7:05 PM, pixelfairy said:

 

Just got my cosmos fixed because the above work around stopped working for me. They just sent me a new one and issue is still there.

I think its a design issue. This is very frustrating, esp knowing how easily it could be fixed! All you have to do is make a separate app or setting for IPD instead of the pop up one! Or both and let us disable it. Either way, its an easy fix! 

 

  • Like 2
Link to post
Share on other sites
Posted (edited)

With the latest update, spotted one hidden function inside the default.vrsettings can actually turn off the IPD pops.
Not sure if it was there already for awhile or just added, but it works for me when change to true.
Try it with your own risk though.

Cheers

 

 

Edited by Crazybird
Link to post
Share on other sites
  • 1 month later...

This annoying popup appears on my Vive pro and Vive pro eye every five minutes, This is the worst experience ever! I have spent too many thousands of dollars on this hardware for this crap to keep occurring. No updates, No firmware fixes, No menu options to disable it, No solution at all, and NO one at HTC gives even the slightest crap (I have called them, emailed them, asked for refunds, RMAs, nothing!!!).

It's like driving on the highway in some fancy sports car but the hood latch constantly keeps flying open and blocking your view of the road. I do not understand why they do not fix this horrible experience, I thought VR was about beautiful immersion; not some annoying popup menus that present meaningless information to users every five minutes because they were having a good time in a game.

My engineering experience tells me this is a issue with hysteresis values being too narrow on the encoder and NEEDS to be widened or OPTIONS ADDED to allow users to simply disable the blinding popups. Just don't forget who is manufacturing these headsets, makes the hardware seem so low quality. My Quest 2 is like a god send compared to this experience, PLEASE FIX YOUR CRAPPY FEATURES TEAM VIVE!

 

Link to post
Share on other sites

It used to be that you could disable the popup by modifying the css in systemui.css. But it's now 2021 and that no longer works!

So I just spent two hours searching through SteamVR code and finally found another way to disable that game breaking popup !!

You have to comment out a single line in C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\webinterface\dashboard\systemui.js which prevents the IPD callback from firing (see attached image).

Enjoy!

Disable IPD.png

Edited by AirMouse
  • Thanks 1
Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...