Jump to content
 
jrmichel2000

Vive Pro + Wireless adapter: screen goes dark

Recommended Posts

For anyone who hasn't seen my post on the other thread. I am reporting very positive results from this fix, this stopped pretty much all of my crashes.
 

 

Share this post


Link to post
Share on other sites
On 3/15/2020 at 1:29 PM, Guy W. said:

Hey all, so I struggled with this for several days, and it looks like I got it. It was a SteamVR issue. In the SteamVR drop menu, under "Developer" I went to "Developer Settings" and was able to "Enable Direct Display Mode" from there. That seems to have done it.

It seems to be related to the new SteamVR sleep settings, that it's putting the screens to sleep. I set both my controllers and screens to 5 minute sleep, and with the controllers sitting dead still and me moving the headset around, they all turned off at exactly the same time.

So for some reason it seems "Direct Display Mode" seems to circumvent this or something? Not sure why. Also not sure why Steam didn't include a "Never Turn Off Displays" option. This would explain why tracking and sound work still while the screen is black though.

I hope this helps someone. And if I come across a related issue, I'll update here.

The "turn off controllers" thing worked! I was tearing my hear out with the HMD going black after a few minutes, but this was the instant fix I was looking for. I set my controllers to "Turn off controllers after 'never'" and bingo, it was solved! 

I also set my displays to turn off after 5 seconds, but I don't think that made a difference. 

Share this post


Link to post
Share on other sites
On 3/18/2020 at 4:16 PM, jrmichel2000 said:

@halcyonWas

@tfmjonny

@Krogenit

You've all done a whole lot of testing and troubleshooting on this. Can you perhaps try this approach and report back in case it resolved the issue for you as well?

It did not help. Also keep getting crashes.

Share this post


Link to post
Share on other sites

Disabling or enabling direct mode didn't work for me either. It goes to a black screen. The workaround I've found is to put the headset down, push the steam button on the wand, and wait a minute. Sometimes I'll cover the proximity sensor too. So far that's worked every time, and takes a minute or two to do. Still annoying.

Share this post


Link to post
Share on other sites

I changed the bios settings to Gen 3 (instead of auto) on my AMD motherboard for the PCI slots and it seems to have resolved the issue.  Couldn't play more than 5 minutes.  Just went an hour without a hiccup.  No other changes made a difference.

  • Thanks 1

Share this post


Link to post
Share on other sites

Try setting the controller timeout to never.

Share this post


Link to post
Share on other sites

I just got my Wireless Adapter Last week and want to thank everyone for the suggestions on the forum.  Mine would cut out (black screen) after nearly exactly 5 mins every time.

Here's what I did all at once Im not sure which one fixed it but so far so good.

-Hooked back up Link Box with just power and USB to computer.

-Had a slight overclock on CPU put that back to normal

- Clicked on PCIeGenConfig.exe file and clicked Enabled

- Set PCI settings in bios from Auto to Gen 3

- Set Controller settings to - Never Turn off

Thank everyone so much for the suggestions I was about to return or burn this thing but now works Great!

Share this post


Link to post
Share on other sites
On 4/2/2020 at 6:45 PM, tommofia said:

I just got my Wireless Adapter Last week and want to thank everyone for the suggestions on the forum.  Mine would cut out (black screen) after nearly exactly 5 mins every time.

Here's what I did all at once Im not sure which one fixed it but so far so good.

-Hooked back up Link Box with just power and USB to computer.

-Had a slight overclock on CPU put that back to normal

- Clicked on PCIeGenConfig.exe file and clicked Enabled

- Set PCI settings in bios from Auto to Gen 3

- Set Controller settings to - Never Turn off

Thank everyone so much for the suggestions I was about to return or burn this thing but now works Great!

👍THX. 👏 It helped. Finally carefree playing. Perhaps it will help others

Share this post


Link to post
Share on other sites
On 3/15/2020 at 4:29 PM, Guy W. said:

Hey all, so I struggled with this for several days, and it looks like I got it. It was a SteamVR issue. In the SteamVR drop menu, under "Developer" I went to "Developer Settings" and was able to "Enable Direct Display Mode" from there. That seems to have done it.

It seems to be related to the new SteamVR sleep settings, that it's putting the screens to sleep. I set both my controllers and screens to 5 minute sleep, and with the controllers sitting dead still and me moving the headset around, they all turned off at exactly the same time.

So for some reason it seems "Direct Display Mode" seems to circumvent this or something? Not sure why. Also not sure why Steam didn't include a "Never Turn Off Displays" option. This would explain why tracking and sound work still while the screen is black though.

I hope this helps someone. And if I come across a related issue, I'll update here.

Turning off controller sleep fixed my issue.  I was using a game controller and not the HTC Vive wands.  The wands were never turned on to begin with but turning off the sleep settings prevented my issue from happening again.  Sincere thanks to you and other posters who reported success also.  I spent a lot of time on this issue before coming across this fix.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...