Jump to content

ViveProSetup.exe installer crashes immediately after being launched


Recommended Posts

Hello Vivers,

I have a very basic, but really frustrating problem:
I bought a ViveProEye and started to prepare the setup by executing the steps which are depicted on the nice chart which was delivered with the package. 
First step is to townload the "ViveProSetup.exe" file from vive.com.
So I did. Then, I ran the installation.
However, the installation process needed to be paused since I unexpectedly did not have the time anymore to continue the setup (it stopped when the computer scanned for the vive devices, headset etc.). Thus, I put my laptop (see system and graphics specs in the pics attached) into "hibernation" mode and intended to re-start the installation setup the next day. 
However, when I tried it the next day, I couldn't run the installer anymore: first, a pop-up window appeared with the message "Severe installation issue present" or something - which does not appear anymore - yet now always the installer crashes when I launch it!
There is now no error message, nothing, just the blue installer (see screenshot) screen for 3-5 seconds which disappears without any notice on why the process stopped. 

I appreciate a lot your support, since I cannot find ANYTHING on the web about this problem which causes a lot of discomfort and disappointment with the product. 

Thanks a lot in advance!

Dalibor

System-specs.jpg

Graphics-specs.jpg

vive-setup-crash.jpg

Edited by dal.and
Link to post
Share on other sites

Additional notes:

1. I do have a smoothly running steam application.

2. I tried to "clean" all Vive-related items from the laptop in order to start the installation process from the beginning and discovered that "VIVE_SRanipalInstaller" is still part of my Apps list (see screenshot) and that it cannot be uninstalled because (see screenshot). 

Is 2. somewhat related to the crashing of the ViveProSetup installer?

VIVE_SRanipalInstaller.msi.jpg

VIVE_SRanipalInstaller.msi-issue.jpg

Edited by dal.and
Link to post
Share on other sites
  • 2 weeks later...

@dal.and

I wonder if it partially installed some drivers which were corrupted by putting your PC into hibernation mode (Never, ever shut down your PC in any way during installations or uninstallations!) and now they can't be properly identified or removed. This tool may help with that. https://support.steampowered.com/kb_article.php?ref=2748-WEIK-9562

Thank you,

-Jack S

Link to post
Share on other sites
  • 1 year later...

I have the same problem bro, the installer crashes during the preparation stage. I installed the software on 4 computers, the software does not work on two, but it works on two, but this is a laptop that does not support VR. VIVE ANSWER us !!!!

Link to post
Share on other sites

@AlexManelda -

  • The Vive Pro installer is unnecessary for standard usage. Just plug the device in and Steam will auto detect a VR headset is plugged in and will let you either launch or install SteamVR.
    • The installer just adds some additional stuff like Viveport, an overlay, and an advanced settings tool which lets you adjust Vive Pro's microphones. All of this is optional in terms of the hardware itself actually working.
  • Use the generic installer rather than the one specific to Vive Pro: https://www.vive.com/us/setup
  • If the installer is crashing straight away, that might indicate that it's not able to contact Vive's servers for the installation package. AV/Firewall could be causing that.
Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...