Jump to content
 
jesse.tsang

ue4 z-fighting

Recommended Posts

Hi @jesse.tsang,

 

Do you assume it's more serious z-fighting on UE on Focus and causing by Wave SDK?

In our understanding, mostly it's handled by content design and there are some tips and discussion to deal with z-fighting in our development experience.

We'll try to pick up some advises and test it to see if it's helpful.

Thanks.

Share this post


Link to post
Share on other sites

Hi@Tony PH Lin 

        Our product was tested on other VR devices(Pico G2) and was not found z-fighting(Same render Settings for the same project).My guess is that the depth buffer precision is not high enough.

Share this post


Link to post
Share on other sites

WaveVR SDK 3.1.1 did not implement the required methods for correctly initializing the near and far clip planes - so they were just stuck on the driver defaults as far as I can tell. The required methods were finally implemented in 3.1.4.

There is literally no way to address this issue in 3.1.1 and anyone suggesting otherwise is misinformed or trying to waste your time.

Edited by sixense
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...