Jump to content
 
daoshengmu_moz

Vive Focus Plus vibration only works on the right-hand controller

Recommended Posts

We are using WaveVR SDK 3.1.1 Beta.

We notice

WVR_TriggerVibration(controller.type, WVR_InputId_Alias1_Trigger, 5000);

only works on the right-hand controller in HTC Focus Plus.

In Focus, because it only has one controller, it can trigger vibration by either WVR_DeviceType_Controller_Left or WVR_DeviceType_Controller_Right on the main controller that is according to the controller setting.

@Cotta @Tony PH Lin

 

Share this post


Link to post
Share on other sites

Hi @daoshengmu

 

Could you clarify first with below conditions?

1) Why your API only have 3 parameters, it should be 5.

Please check below link for detail.

https://hub.vive.com/storage/docs/en-us/WVR_TriggerVibration.html?highlight=wvr_triggervibrator

2) Do you also switch from Launcher Setting (Left/Right Hand) when you test it?

3) Can you confirm if your controller is good w/o broken?

Thanks.

 

 

Share this post


Link to post
Share on other sites

Maybe you should use 

private WaveVR_Controller.Device nonDominantController;

Start()
{
	nonDominantController = WaveVR_Controller.Input(WaveVR_Controller.EDeviceType.NonDominant);
    nonDominantController.TriggerHapticPulse();
}

 

Edited by Fangh
  • Like 1

Share this post


Link to post
Share on other sites
On 9/10/2019 at 4:32 AM, Tony PH Lin said:

Hi @daoshengmu

 

Could you clarify first with below conditions?

1) Why your API only have 3 parameters, it should be 5.

Please check below link for detail.

https://hub.vive.com/storage/docs/en-us/WVR_TriggerVibration.html?highlight=wvr_triggervibrator

It doesn't need to be 5 parameters because it has default parameters. I tried `WVR_TriggerVibration(controller.type);` too. There is only one controller from my hands can do the vibration.

 

On 9/10/2019 at 4:32 AM, Tony PH Lin said:

2) Do you also switch from Launcher Setting (Left/Right Hand) when you test it?

3) Can you confirm if your controller is good w/o broken?

Thanks.

 

 

I start feeling one of my controllers is broken because this function works for my team member's two controllers.

Share this post


Link to post
Share on other sites

Hi @daoshengmu_moz,

Thanks for your feedback.

If you can confirm one of controller is broken, I suggest you to contact with our region support to return or exchange (I'm not sure the detail of this service process, and there should be a service center when you purchase the device).

Let us know if you still need further technical support.

Thanks.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...