Jump to content

Vive Pro Eye Calibration Initialization Error Troubleshooting


Recommended Posts

@VibrantNebula my problem is not so much with the calibration itself, but with the UAC popup. If you want me to start a new thread, let me know.

Here's what happens.

Every first time I run calibration after starting up my PC I get the UAC popup asking if it is ok to allow Vive-Super-Reality-SR_Runtime to make changes to this PC. It makes no difference if I start calibration from SteamVR, from the Unity editor or from a Unity application.exe. If I click Allow, then all subsequent starts work right away. Also if I first run it from my application.exe and then from SteamVR.

Since the popup blocks the whole screen I can not go to the SR-runtime icon and pack-log.

This is a new MSI laptop, Windows 10, with a clean install of SteamVR and SRanipal. I created only one account on this PC and according to Windows accounts it has administrator rights. I did not change any access rights settings for SRanipalRuntime.exe yet, because I see mixed reactions. I do see that there are settings for users, administrators and for applications. maybe that is a clue? I attached the settings (I hope the order is the same in all languages 🙂)

I hope you can help me with this. I need to install a Vive with eyetracking at a customer later this month and since it is a large organisation I'm sure the IT department will not allow me to disable UAC control completely. And I don't want to tell the customer 'Well, if you want to use eyetracking you need to start this manually first', or that they need to take off the headset, click ok in the popup and then continue the application.






Link to comment
Share on other sites

@jboss - It generally helps to follow a specific order of operations. From a clean reboot/login, right click the shortcut/app for SR_Works and click "run as administrator" and accept the UAC prompt before you boot SteamVR, the calibration app, or anything else. Just start SR_Runtime first and bypass that UAC.

You can also just boot everything with full admin access but that may not be compatible with your operation environment.

The UAC situation is a result of how the underlying Tobii runtime works and as a result, Vive doesn't have a ton of options down the line in the SR_Runtime.

I might recommend copying this message and contacting support.enterprise@htc.com as this is an enterprise oriented problem.

Link to comment
Share on other sites

@VibrantNebula I agree that if you start the SR-runtime manually first before any application it works fine. But as a user (enterprise or consumer, I don't think this is an enterprise problem) you have to remember that. Every time! Because if you forget, it breaks the immersiveness of VR. You have your headset on and you get the message "next up... Your application' and it just stays there. Because on screen there is the UAC popup. So you have to take off the headset, click OK and put the headset on again. Not a good experience of VR.

I changed the properties of SR-runtime.exe to always run as administrator, but that makes no difference, as other users have reported as well.

I then had a brainwave, what if I run SR-runtime at startup automatically. Then you can't forget. Well, that didn't work either. I had to copy (not link, actual copy; weird Windows logic....) it to the Startup folder, but when I then started calibration the three blue dots froze and disappeared. And then the Vive Pro Eye option was gone from the SteamVR in-world system menu. So I copied it back to the original location.

Since you mention it is related to the Tobii runtime environment, I hope you will take this up with them. I think I will do that as well, but if the request comes from HTC it may have more leverage.

Link to comment
Share on other sites

@jboss I am referring you to enterprise support specifically because Pro Eye is an enterprise SKU and not a consumer SKU. It has a different support pipeline and that team may have helpful input.

If the SRRuntime is UAC approved and running in the tray, then I'm not sure what's prompting the second UAC prompt.

I unfortunately don't think a more permanent solution is on the near-term horizon because of how how the tech stack works. Fixing this would apparently require fairly substantial rework.

Link to comment
Share on other sites

@jboss It is possible to have the runtime start with windows startup and only require the UAC prompt once. 

Copy the app shortcut (the one created on the desktop during install) to the windows startup folder (%APPDATA%\Microsoft\Windows\Start Menu\Programs\Startup)


Link to comment
Share on other sites

  • 1 month later...

When I check the status of the Tobii VR02 Runtime service it is stopped. When I then start it I immediately get a pop-up message:

"The Tobii VR02 Runtime service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

This is with the SRanipalRuntime running in the system tray with orange status.

The initialization, of course, fails when I try to run a calibration.

I have purchased two Vive Pro Eyes so far and was planning to get more - unless this issue is solved I think I'll give up on this system - it isn't fit for purpose.


Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...