Jump to content
 
Corvus

Vive Pro Eye Calibration Initialization Error Troubleshooting

Recommended Posts

On 2/4/2020 at 7:41 PM, PheonixLab said:

Thanks for the reply!

After the installation of SR Runtime and confirming the status of idle from the SR Runtime task bar, neither the EULA pop-up nor a calibration compositor menu option appear within SteamVR.

In attempting to resolve this I have gone into the Vive->SRanipal->tools directory and tried executing the "EyeEULA.exe" which does start the loading screen, but ultimately ends with the Initialization Error.

Additionally I have found that running the "dashboard.vrmanifest" within the tools->SRanipal->eye_calibration_dashboard does add the dashboard menu to SteamVR, however this still ends with the same error as above. (backwards attempt but someone had mentioned earlier executing calibration within SteamVR resolved the issue for them)

I ensured Steam, SteamVR, Unity, GPU drivers, the Eye Pro etc... are all up to date.

I have tried uninstalling and reinstalling SR Runtime and SteamVR several times.

@Corvus @Daniel_Y @Jad

Now it no longer shows idle in the SR_Ranipal task menu icon unless I detach the Eye Pro from the base station then reconnect it...

@Corvus @Daniel_Y @Jad

Share this post


Link to post
Share on other sites

Dear @Corvus @Daniel_Y @Daniel_Obrien

I get the following error which is different to what you mentioned. 

 

[SRanipal] Initial Eye v2: NOT_SUPPORTED
UnityEngine.DebugLogHandler:Internal_Log(LogType, LogOption, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:LogError(Object)
ViveSR.anipal.Eye.SRanipal_Eye_Framework:StartFramework() (at C:\Users\dn0855\Documents\UnityProj\Speed_Normal\Assets\ViveSR\Scripts\Eye\SRanipal_Eye_Framework.cs:104)
ViveSR.anipal.Eye.SRanipal_Eye_Framework:Start() (at C:\Users\dn0855\Documents\UnityProj\Speed_Normal\Assets\ViveSR\Scripts\Eye\SRanipal_Eye_Framework.cs:59)
 

 

I have tried different solutions, but I continually get the error. What's can I do? 

The icon in the system tray on my computer is always brown color.

 

Best,

Share this post


Link to post
Share on other sites

Dear  @原田空来  @PheonixLab @Jad  @Nermeen  @idontwantthis

(I am sorry for repetively posting because I posted in a wrong place before )

My eye tracker suddenly doesn't work, could you explain me more in detail how did you fix the problem? I ran into the same problem. Thank you very much. I am frustrating also.

Google translation from English to Japanese for @原田空来

アイトラッカーが突然動作しません。問題をどのように修正したのか、詳しく説明してもらえますか?
ありがとうございました

Share this post


Link to post
Share on other sites

I am running into this problem both fom the SteamVR menu and from Unity. I did some troubleshooting, but haven't found a clear repeatable behaviour yet. I tried setting EyeCalibration.exe to run as admin always, but that does not seem to make a difference. Since I need to invoke it from Unity I can't set this at runtime (but I still have to, but I'll get to that). Also running this .exe manually before running my Unity application is not a good solution for my customers. I have the latest SteamVR and Sr and Tobii version installed.

Here's what I did and the calibration behaviour. I ran these test with EyeCaliration not running as administrator.

Testcase 1
Restart my PC
Run calibration from inside SteamVR: got the UserAccountControl popup asking for permission for SRanipal. Clicked allow en got Initialization Failed in the calibration.
Run it again from inside SteamVR and now it works fine, without UAC popup
Run it once more from inside SteamVR and again runs fine.
Quit SteamVR
Restart SteamVR
Run calibration from inside SteamVR and this time it failed, but without the UAC popup
Run it again from inside SteamVR and it runs fine.
Quit SteamVR
Restart SteamVR
Run calibration from inside SteamVR and this time it worked fine.
Start my Unity application from the .exe file
Run calibration from inside Unity exe and it worked fine
Quit Unity application exe file
Start my Unity application from the Unity editor
Run calibration from inside Unity editor and it worked fine

Testcase 2
Restart my PC
Start my Unity application from the .exe file
Run calibration from inside Unity application: got the UserAccountControl popup asking for permission for SRanipal. Clicked allow en got Initialization Failed in the calibration.
Run it again from inside Unity application and now it works fine, without UAC popup
Quit Unity application exe (this caused a SteamVR crash, don't now why)
Start my Unity application from the Unity editor
Run calibration from inside Unity editor: got the UserAccountControl popup asking for prermission. Clicked allow en got Initialization Failed in the calibration.
Run it again from inside Unity editor and now I got Initialization Failed, but without UAC popup
Run it once more from inside Unity editor and now it worked fine
Quit Unity editor (SteamVR is still running)
Run calibration from inside SteamVR and now it works fine, without UAC popup

So, no real pattern. At one point I thought I crashed only the first time because of the UAC popup, but the tests show that that is not always true. I noticed that when I quit my application exe file (had to do this from the task manager because it was running fullscreen) that the EyeCalibrationDashboard.exe was running. I checked if that started at the same time as EyeCalibration.exe, but it seems not to.

Hope someone can find a way tro solve this. Like I said, for customers this is not user-friendly.

Thanks.

@Corvus

Share this post


Link to post
Share on other sites

New HTV Vive user.  I'm having the same issue here.  I've tried some of the things in the first post but my PC is for work and I have to take it to IT for anything installation-related so I'm hoping to avoid that.  I do have the SR_Runtime going as an admin (had them remote in for that).   Still fails to initialize the calibration for eye tracking.   Any updates?

Share this post


Link to post
Share on other sites
On 5/12/2020 at 10:44 PM, tamu.bhp said:

New HTV Vive user.  I'm having the same issue here.  I've tried some of the things in the first post but my PC is for work and I have to take it to IT for anything installation-related so I'm hoping to avoid that.  I do have the SR_Runtime going as an admin (had them remote in for that).   Still fails to initialize the calibration for eye tracking.   Any updates?

 

Try this post, we did it: 

 

 

 

Share this post


Link to post
Share on other sites

I got rid of the popup by disabling User Account Control completely. This is of course not what you want and also not what you want to tell your customers.

On the other hand, one of the partners that I develop for does not report the issue, so it could be related to which account is used when installing the Vive software. Other threads also suggest that running it when looged in with the Windows administrator account works (which is the actual Administrator account, not a user account with Administrator properties, I guess, so also Run As Administrator will not help). I also noted before I disabled UAC that if I had allowed it once it woulld run without popup for subsequent checks. But as soon as I restarted the PC it needed permission again.

Share this post


Link to post
Share on other sites
29 minutes ago, jboss said:

I got rid of the popup by disabling User Account Control completely. This is of course not what you want and also not what you want to tell your customers.

On the other hand, one of the partners that I develop for does not report the issue, so it could be related to which account is used when installing the Vive software. Other threads also suggest that running it when looged in with the Windows administrator account works (which is the actual Administrator account, not a user account with Administrator properties, I guess, so also Run As Administrator will not help). I also noted before I disabled UAC that if I had allowed it once it woulld run without popup for subsequent checks. But as soon as I restarted the PC it needed permission again.

@jboss Thanks, but I don't understand what is the "User Account Control" referring to. Could you explain about it? Is it the Steam Account or the PC admin account? Thank you. 

 

Share this post


Link to post
Share on other sites
Posted (edited)

It's the Windows User Account Control.

Rightclick on the Start menu icon and select Search. Then type UAC and should see something like (don't have the English Windows version) 'Change settings for User Account Control'. You can also get there through the Configuration screen --> User Accounts --> User Accounts.

In the popup you need to move the slider all the way down. Yes, that is the 'Not recommended' setting.

Edited by jboss

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...