Jump to content

Vive Pro Eye Calibration Initialization Error Troubleshooting


Recommended Posts

On 12/9/2019 at 6:13 PM, aarelovich1984 said:
Quote

For those interested, I've managed to solve the issue. It was not enough to simply run SR Runtime in Administrator Mode. I fixed it by actually using an administrator account. This is a huge security issue depending on who uses your windows PC as it is FAR easier for unwanted stuff to get installed in your PC when, say, surfing the web. But it does fix the problem, at least for me. 

This hasn't solved it for me; I've been using a full administrator account the whole time, and running SR Runtime as administrator.

@zzy @Corvus

Link to post
Share on other sites
  • Replies 45
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Vive Pro Eye Calibration Initialization Error Troubleshooting Problem: Launching calibration shows error: "Initialization Failed" Solutions: - Run "EyeCalibration.exe" manually in C:\Pro

Hello all - we're putting an increased focus on working 1:1 with affected users as we try to hone in on why Windows appears to be conflicting with the runtimes. If you are affected by this issue, plea

Posted Images

On 2019/11/27 at 午後12時34分, 原田空来 said:

先月の下旬に購入したVIVE PRO EYEが、今週の月曜に急にアイトラッキングができなくなってしまいました。キャリブレーションの初期化もできないです。

先週までは、何事もなくアイトラッキングできました。

自分はパソコンとVIVEの相性が悪く、パソコンを変えたところアイトラッキングできるようになりました。

Link to post
Share on other sites
On 12/16/2019 at 5:13 PM, andrea said:

I'm terribly sorry not to have answered sooner, Andrea, but unfortunately I can't help you. It seems the issues are basically computer setup dependent, which is something very very bad. But I have been using, although rather unsuccessfully, eye tracking since that day. I hope you can find a fix. 

Link to post
Share on other sites
  • 3 weeks later...
On 9/6/2019 at 2:08 PM, Corvus said:

Vive Pro Eye Calibration Initialization Error Troubleshooting

Problem:
Launching calibration shows error: "Initialization Failed"

Solutions:

- Power off/on PC & Link Box.
- Run 'sr_runtime.exe' as Admin. Default install path: 'C:\Program Files (x86)\VIVE\SRanipal'.
- Update SteamVR Runtime.
- Update graphics card drivers.
- Possible issue with some models of MSI laptops fixed with rollback to earlier NVIDIA driver. Fresh install of NVIDIA driver 417.71 (GPU BIOS not being updated and it does not support the latest NVIDIA driver).
- Uninstall 'VIVE_SRaniaplInstaller' & 'Tobii VRU02 Runtime'. Restart and Install latest 'VIVE_SRanipalInstaller_1.1.0.1.msi'. Plug in HMD and wait for any updates to complete.
- Update motherboard integrated Intel Graphics Driver (fixes system reference to incorrect openCL.dll (intel) instead of NVidia).
- Disable integrated graphic card
- Possible issue with wireless adapter, try running calibration with wired.
- Possible issues with early dev kits.

Check System Requirements:
- Use DisplayPort, mini-DisplayPort, or USB-C output from the dedicated GPU.
- Windows 8.1 or later (64-bit).

 

I have Win 7. I was able to do the calibration in July without any problems. When I try it now, I get the Initialization Error. Could it be because I need to upgrade to Win 8 or later? 

But it worked fine before with my current windows!

@Corvus @Daniel_Y

Link to post
Share on other sites
  • 2 weeks later...
On 12/7/2019 at 3:07 PM, aarelovich1984 said:

Hello I've recently JUST installed the HTC Vive Eye Pro. I have not managed to get the EyeTracking working in order to test it out. I have had the same problem everyone else here described. 

I'm using the following desktop computer::

MSI Nvidia GTX 1060 3GB RAM

Core I7 4790K CPU

8 GB RAM

Windows 10

 

I'm attaching the packed logs.

I believe the main problem can be identifiied in the EyeCameraModule where I get the following set of errors:

[EyeCameraModule] [2019-12-07 16:46:48] [-!-ERROR-!-] [CODE: 0x0000] [DEBUG]           prp_client.cpp(942): error "PRP_ERROR_ENUM_CONNECTION_FAILED" (00000003) in function "prp_client_process_subscriptions" @thr_main::<lambda_8cd30f5459673188ae9c0fd5bb8c5d55>::operator ():339
[EyeCameraModule] [2019-12-07 16:46:48] [-!-ERROR-!-] [CODE: 0x0000] [ERROR]           device.cpp(1836): error "DEVICE_ERROR_CONNECTION_FAILED" (00000004) in function "process_callbacks" @thr_main::<lambda_8cd30f5459673188ae9c0fd5bb8c5d55>::operator ():326
[EyeCameraModule] [2019-12-07 16:46:48] [-!-ERROR-!-] [CODE: 0x0000] [ERROR]           eyetracker.cpp(260): error "TOBII_ERROR_CONNECTION_FAILED" (00000005) in function "eyetracker_device_process_callbacks" @thr_main::<lambda_8cd30f5459673188ae9c0fd5bb8c5d55>::operator ():326

These are repeated over and over again.

Any help would be greatly appreciated. 

ViveSR_Log.zip 13.76 kB · 0 downloads

 

@Corvus

 

After installing the SR Runtime I never received the notice to enable or calibrate, though SR Runtime does show the device in idle.

I inspected the Pack Log and found I am getting these exact same errors. In addition under LCameraModule.log I am getting the following in repeat:

[LCameraModule] [2020-02-04 15:02:03] [LOG] [Init] camera count 1
[LCameraModule] [2020-02-04 15:02:03] [LOG] [Init] Can not find camera: USB Camera-OV580
[LCameraModule] [2020-02-04 15:02:03] [LOG] [destroy]

 

Without eye tracking this headset is pointless. What is causing this and how might I resolve this?

 

@Corvus @Daniel_Y @Jad

 

Link to post
Share on other sites
2 hours ago, Corvus said:

@PheonixLab Have you accepted the EULA and tried to calibrate via the SteamVR compositor menu?

Thanks for the reply!

After the installation of SR Runtime and confirming the status of idle from the SR Runtime task bar, neither the EULA pop-up nor a calibration compositor menu option appear within SteamVR.

In attempting to resolve this I have gone into the Vive->SRanipal->tools directory and tried executing the "EyeEULA.exe" which does start the loading screen, but ultimately ends with the Initialization Error.

Additionally I have found that running the "dashboard.vrmanifest" within the tools->SRanipal->eye_calibration_dashboard does add the dashboard menu to SteamVR, however this still ends with the same error as above. (backwards attempt but someone had mentioned earlier executing calibration within SteamVR resolved the issue for them)

I ensured Steam, SteamVR, Unity, GPU drivers, the Eye Pro etc... are all up to date.

I have tried uninstalling and reinstalling SR Runtime and SteamVR several times.

@Corvus @Daniel_Y @Jad

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...