Jump to content

VR Camera Shake not shaking


FrancescoFontana
 Share

Recommended Posts

Hi everyone,

I am trying to add a camera shake following this tutorial:

http://www.zulubo.com/gamedev/2019/1/5/vr-screen-shake-the-art-of-not-throwing-up

Sadly, while it works inside the unity editor (I'm using Unity 2018.2.21f1) it does nothing while deployed inside the Vive Focus Plus.

 

You coul find the slightly modified script attached here, if anyone could point me in the right direction it will be amazing, and perhaps it will benefit other users as well ­čÖé.

Thank you,

Francesco

ScreenShakeVR.shader ScreenShakeVR.cs

Link to comment
Share on other sites

Hi @FrancescoFontana,

One possible reason is that you'll have to set 'Preferred Stereo Rendering Path' to 'Multi Pass'. WaveVR doesn't support Post Process + Single Pass at current stage. Also, per checked this shader is not designed for Single Pass case.

shader_02.png.09a06e15e7908be57b6d0cd2ccaa6707.png

We verified this shader works inside Focus Plus when set to Multi Pass. Note that you'll need to attach the script to both Eye Right and Eye Left.

shader_01.png.02da141987e24eb375bae3c345670a55.png

Make sure to place the shader in Resource folder to be loaded correctly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

├Ś
├Ś
  • Create New...