Jump to content
 
BackWithPipes

Vive Pro + Wireless jitter stutter every 3 seconds

Recommended Posts

Any updates with this?
Am having the exact same issue that only seemed to start occurring with the Steam VR 1.7.15 update.

There is likely some sort of interference or hiccup that I cant figure out as it worked before and dosent now.

This video shows the display when using Steams "Display VR View"

https://www.youtube.com/watch?v=c_HtaS8ghwE

This video shows the view looking through the lens (recorded with a phone). The regular pixelated fuzzing/jumping is what you see and its quite distracting.

https://www.youtube.com/watch?v=53FRWnWYylE

Its very consistent in its timing.

frames.thumb.PNG.1869d8c5673551b0f9b9fc02b7f9d8de.PNG

Not sure why but the compositor eats up as much CPU as possible when anything is running, I've seen up to 60% so not sure if that's part of the issue.

compositor.PNG.cae7f30cb2490ad32d732f41d1cacdfd.PNG

Lastly, I noticed the same peeking in my network tab as well, regular and consistent with the fuzzing issue. Disabling the wifi card entirely doesn't change the issue though.

network.PNG.261a493484bda10abbd4bd630c88ccc9.PNG

If I exit Steam VR but leave the VIVE Wireless program running, the network peaks go away.

If I have Steam VR running but no program (including no Steam Home so its just the borealis area) the fuzzing goes away.

idlehome.PNG.876f08501c6b22b555b3497a84124c12.PNG

 

I really have no idea how to fix this and, since there's no way to roll back to a previous version of Steam VR, I have no way of knowing if its something to do with the update.

Sheet Specs:

Win10 Home

Intel Core i5-9400F 2.9GHz (OC to 3.9)

16GB SDRAM DDR4 2666

1TB SATA III 3D NAND (SSD)

NVIDIA GeForce RTX 2070 Super

TP-LINK 802.11ac Wireless Network Adapter

And, of course, the Intel Wireless Gigabit VR Adapter card

 

If ya'lls have any ideas that would be awesome :)

Thanks,

 

Share this post


Link to post
Share on other sites
15 hours ago, Dracasis said:

Any updates with this?
Am having the exact same issue that only seemed to start occurring with the Steam VR 1.7.15 update.

There is likely some sort of interference or hiccup that I cant figure out as it worked before and dosent now.

This video shows the display when using Steams "Display VR View"

https://www.youtube.com/watch?v=c_HtaS8ghwE

This video shows the view looking through the lens (recorded with a phone). The regular pixelated fuzzing/jumping is what you see and its quite distracting.

https://www.youtube.com/watch?v=53FRWnWYylE

Its very consistent in its timing.

frames.thumb.PNG.1869d8c5673551b0f9b9fc02b7f9d8de.PNG

Not sure why but the compositor eats up as much CPU as possible when anything is running, I've seen up to 60% so not sure if that's part of the issue.

compositor.PNG.cae7f30cb2490ad32d732f41d1cacdfd.PNG

Lastly, I noticed the same peeking in my network tab as well, regular and consistent with the fuzzing issue. Disabling the wifi card entirely doesn't change the issue though.

network.PNG.261a493484bda10abbd4bd630c88ccc9.PNG

If I exit Steam VR but leave the VIVE Wireless program running, the network peaks go away.

If I have Steam VR running but no program (including no Steam Home so its just the borealis area) the fuzzing goes away.

idlehome.PNG.876f08501c6b22b555b3497a84124c12.PNG

 

I really have no idea how to fix this and, since there's no way to roll back to a previous version of Steam VR, I have no way of knowing if its something to do with the update.

Sheet Specs:

Win10 Home

Intel Core i5-9400F 2.9GHz (OC to 3.9)

16GB SDRAM DDR4 2666

1TB SATA III 3D NAND (SSD)

NVIDIA GeForce RTX 2070 Super

TP-LINK 802.11ac Wireless Network Adapter

And, of course, the Intel Wireless Gigabit VR Adapter card

 

If ya'lls have any ideas that would be awesome 🙂

Thanks,

 

I know that in the time of windows XP, the OS frequently check for new wireless networks. This service could be disabled in XP, but in Win7 or Win10 did not able to turn off this service. This was a 5 second interval at the time of XP.

Also there is a Motherboard thing.
Make sure that you run the latest bios firmware, turn off hardware monitor options (temperatures and fanspeed) in bios and do not run any monitor software. Try to fix you CPU speed.

Because the PCIe bus is very busy with handling the data from your GPU to the WiGiG card, make shure your GPU is in the fist slot en the the WiGiG card.

Also I see that your CPU is already running 100%. So you don't have any overhead on the CPU. Because wireless is GPU and CPU depending make shure to shutdown all application that you dont need.
Als you can try to set the CPU priority higher then standard.  Check this https://www.tenforums.com/tutorials/89548-set-cpu-process-priority-applications-windows-10-a.html

I was not able to get the wireless working with my "old" pc. (for the specs read the first post). I did buy a new PC instead.
@Dracasis Can you post you Motherboard specs here?

Edited by BackWithPipes

Share this post


Link to post
Share on other sites

I recently started to use my wireless vive  again and while I had solved this issue in the past.... it has now returned

First thing, kill steamtours.exe. It is for steam home but absolutely trashes your CPU and subsequently the wireless gets impacted. This had solved me in the past but I don't see it as a process anymore so I'm stumped

Now I'm in the same boat of a stutter every 4 seconds and my CPU usage is minimal (beat saber or lazer vr as examples). Mininimal being 75% or less

Edited by Keyes

Share this post


Link to post
Share on other sites
On 9/24/2019 at 11:31 AM, BackWithPipes said:

I know that in the time of windows XP, the OS frequently check for new wireless networks. This service could be disabled in XP, but in Win7 or Win10 did not able to turn off this service. This was a 5 second interval at the time of XP.

Also there is a Motherboard thing.
Make sure that you run the latest bios firmware, turn off hardware monitor options (temperatures and fanspeed) in bios and do not run any monitor software. Try to fix you CPU speed.

Because the PCIe bus is very busy with handling the data from your GPU to the WiGiG card, make shure your GPU is in the fist slot en the the WiGiG card.

Also I see that your CPU is already running 100%. So you don't have any overhead on the CPU. Because wireless is GPU and CPU depending make shure to shutdown all application that you dont need.
Als you can try to set the CPU priority higher then standard.  Check this https://www.tenforums.com/tutorials/89548-set-cpu-process-priority-applications-windows-10-a.html

I was not able to get the wireless working with my "old" pc. (for the specs read the first post). I did buy a new PC instead.
@Dracasis Can you post you Motherboard specs here?

Its a brand new PC I bought specifically to do VR and it was working fine for about a month. I was playing Beat Saber, modded SkyrimVR and Arizona Sunshine on it without a hitch and this problem litteraly popped up out of nowhere. Because it was working previously I have a harder time believing its hardware related. Motherboard is an ASRock H370 Pro4 https://www.asrock.com/MB/Intel/H370 Pro4/index.asp

Cards inserted into the MB are Wi-Gig, GPU, Wireless adapter.

Not sure what you mean by 'fix your CPU' speed. The i5-9400F is a  2.9GHz processor currently turboclocked to 3.9GHz.

Unfortunately I cant effect what CPU usage the compositor is chugging: at just the idle screen it chews 60% of the CPU but when in an actual application it usually falls back to 30-50%. I can only assume its using all available CPU for its own processes and just dials back when other applications need it. There's no way the compositor should need to use 60% of a 6 core 3.9GHz processor doing 'nothing'. Setting CPU priority did not change the effect or I dont know what application needs priority.

 

On 9/24/2019 at 8:22 PM, Keyes said:

I recently started to use my wireless vive  again and while I had solved this issue in the past.... it has now returned

First thing, kill steamtours.exe. It is for steam home but absolutely trashes your CPU and subsequently the wireless gets impacted. This had solved me in the past but I don't see it as a process anymore so I'm stumped

Now I'm in the same boat of a stutter every 4 seconds and my CPU usage is minimal (beat saber or lazer vr as examples). Mininimal being 75% or less

Steamtours.exe is the steam home application which quits on its own when a new VR application is run. Force quitting it did not effect the stutter for me either.

  • Like 1

Share this post


Link to post
Share on other sites

Cool. Spent a few hours trying to narrow down the issue. Some hardware and software adjustments and the final thing that worked was giving 'high' CPU priority to the vrcompositor. Kinda happened by accident cause 'above average' didn't do anything. Downloaded a program to give it high priority permanently and seems to be resolving the issue. I'm guessing something in the latest steamvr update buggered CPU allocation.

Hopefully that'll help someone in the future.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/30/2019 at 2:07 AM, Dracasis said:

Cool. Spent a few hours trying to narrow down the issue. Some hardware and software adjustments and the final thing that worked was giving 'high' CPU priority to the vrcompositor. Kinda happened by accident cause 'above average' didn't do anything. Downloaded a program to give it high priority permanently and seems to be resolving the issue. I'm guessing something in the latest steamvr update buggered CPU allocation.

Hopefully that'll help someone in the future.

I spent a few hours last night troubleshooting this issue, as I also had no issues at all wired, and fuzzy pulse with wireless. I've got an OC'ed 2500K and a brand new 2070 SUPER, and setting the priority to "High" for vrcompositor in task manager was the only thing that got rid of the fuzzy pulse for me. Just wanted to say thanks; it was nauseating.

Share this post


Link to post
Share on other sites

I've started having this exact problem immediately after a firmware update over a month ago. Chart looks just like @BackWithPipes. It's not hardware, it all worked fine for over a year until that update. I haven't been using the wireless since then waiting for a fix. The developers need to get their act together and get this crap straitened out.  Somebodies responsible and it sure isn't the users.  Get it fixed Vive. 

Share this post


Link to post
Share on other sites

I had problems with low frame rate, stuttering, pixels and so on every 10-15 seconds on AMD CPU. Solution that worked for me: better cooler, that keeps CPU temperature below thermal margin and additional system fans for better air circulation inside PC case.

CPU Stress.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...