Jump to content

Recommended Posts

hi there, i m into a situation where i m not able to click on UI buttons... 
1. i created lookat function for UI canvas which is attached to empty gameobject (parent of canvas) whose rotation is 0 and child (canvas rotation is 180) 

2. when i teleport to different position and try to click on UI button not able to click, the controller ray is passing through UI object 

@Cotta @Tony PH Lin

Link to post
Share on other sites

Hi @1128,

Several questions that may help us to clarify it.

  1) The version of WAVE SDK. Are you using 3.0.2?

  2) Do you use InputModuleManager and ControllerLoader prefab?

  3) Which Raycast Mode do you use? Mouse or Beam?

  4) It's good before teleport, right?

It may be helpful for you to check the WaveVR sample 'Teleport_Test'.

Link to post
Share on other sites

1- yes i m using wave sdk version 3.0.2

2- yes i use both inputModuleManager and controllerLoader prefab

3- I m using beam

4- there is no problem in teleporting

hope i answered all the questions you asked

Link to post
Share on other sites

Hi @1128,

For #4, the real question is if this problem (controller ray passing through UI button) happens 'only after' doing teleport? We asked because you said in the first post: when i teleport to different position and try to click on UI button... Does that mean 'before doing teleport' you were able to click on the UI button?

I'm passing the info you provided to the RD team and see if any clue we can find about the problem you met.

Link to post
Share on other sites

thank you for reply i m hoping that will get solution for this from the RD team.  And one more thing, i m able to click on UI button even after teleporting. i m thinking that this issue is happening because of rotation (at some angle ) issue on the canvas parent (parent has lookat function script attached). my teleport script is casting ray from the controller, there i checking trigger function on the floor for teleporting.

 

thank you.

Edited by 1128
providing more detail about the issue
Link to post
Share on other sites

looks like the problem is fixed, i m able to click on UI button from any position thank you so much.  one more thing that with beam mode - if i m too far from UI the pointer will not exactly hover on UI. i have raised this question earlier also. 

i have one more question as well

1. what should be the gameobjects scale so that it feels like we are in realworld (like for hololens they mentioned the objects scale should be 0.1)?

2. what should be the field of view of camera.

Link to post
Share on other sites

Hi @1128,

It's great to hear the problem is fixed. Do you mind to post the new questions in another thread with a different title? It will be more convenient for other members searching if their questions have been discussed before. Thank you.

I will check with the team on the new questions first in parallel. 

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...