Jump to content
 
Sign in to follow this  
perha

How to prevent computer from logging out during usage of the Vive?

Recommended Posts

Hello,

Some computers and work environments use the HTC Vive in accessible workstations for users in the workspace, for example at a library or office. However, for security reasons, the computers at use generally have an automatic hard log out after a period of inactivity (lets say 10 minutes), where inactivity is determined by keyboard or mouse input. However, while using the Vive, the user receives no warning and the inputs from the Vive and controllers do not count as activity, causing log outs mid way through a session and deleting data. How do you prevent this? The logical solution would be to include movement of the headset or controllers as activity, however this information cannot be sent to the desktop, from what I understand.

I would like to note that solutions that suggest that the log out feature is entirely removed are not acceptable, since workspaces keep automatic log outs for security reasons and this should be considered as part of the problem. The computer should log out if it determines there has been ten minutes of idleness: no user input.

The workspace I work with has a workstation with the HTC Vive headset and two motion controllers and runs on Windows 10.

Is there any way to do this currently? And if not, could this be implemented?

Thanks!

Share this post


Link to post
Share on other sites

@perha This sounds like it's likely a Windows policy or configuration issue on your workstations. SteamVR in the vast majority of deployment scenarios (i.e. every installation I've ever had firsthand experience with) will actually prevent the computer from locking when an active SteamVR session is rendering by default. Most users actually have the exact opposite problem wherein an idle SteamVR Window prevents windows from automatically locking the PC (when inactive) which creates a security vulnerability by preventing the PC from auto-locking. We actually have to commonly instruct enterprise users on how to configure SteamVR to shut down after an idle period to re-enable the computer from automatically locking (via SteamVR's power management settings panel). I'm honestly not sure what's occurring on your workstations, I've never heard of this specific problem as we're usually dealing with the compositor preventing the PC from locking which makes me believe it's related to your Windows policies or power management settings. It may also be related to your GPU driver and settings.

With all of that said, SteamVR had a longstanding feature to enable the HMD to keep rendering when the headset is locked as this is a key requirement for developers and those who work in secured environments. You can enable locked rendering via SteamVR -> Settings -> Enable headset when computer is locked. That won't help you however if your Windows policies are forcing the computer to log out rather than simply lock the session. You should likely be locking your desktop when the HMD is in use if you're in a secured environment in any case. You may need to ask your sysadmin to adjust your policies on the machines in question to lock the PC rather than fully log-out due to inactivity.

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...