Jump to content

SRanipal Start Calibration fails


Recommended Posts

Sorry to hear you are having some issues on specific PCs. Let's try to narrow down the issue and get it working for you! Here are some questions and suggestions to get started:

 

Are you using Windows 8.1 or later (64-bit)?  --- All computers involved are Windows 10 Pro (64bit)
What version of SteamVR are you using?   --- 1.5.9
Do you have admin rights on the logged in account? Do you see and accept the Windows UAC popup?  --- Yes admin rights.  Yes popup, always accept.
Do you have the robot face icon in the notification tray?  --- Yes, it starts with gray eyes, they orange and turn to green sometimes.
With the Pro Eye plugged in and link box powered on, does the notification icon robot have black eyes or are they green/red?  --- Answered above
If you right-click the notification icon and select "About", what eye camera version is shown or is it "N/A"? 1.88.0-8106667


Can you try uninstalling these:
- Tobii VRU02 Runtime
- VIVE_SRanipalInstaller

Restart PC.
Install latest runtime (VIVE_SRanipalInstaller_1.0.3.0.msi)

Plug in HMD and wait for any updates to complete.

 

I have done this exact procedure for 4 versions 0.8.x.x, 1.0.x.x, 1.0.1.x and 1.0.3.x (mentioned previously).  With and without manually deleting all files/folders that match both SRanipal and Tobii on my computer (since the uninstall doesn't seem to remove them and going back to a previous version doesn't work without this).


If you are still having issues can you post or PM me a SteamVR system report?
SteamVR > Settings > General > Create System Report

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

We are looking into this issue and I would like to share a possible workaround in the mean time. If anyone else is experiencing this calibration "initialization failure" error please post here or pm me so we can follow up if necessary.

 

Temporary workaround for calibration "initialization failure" error:

- uninstall "VIVE_SRanipalInstaller" & "Tobii VRU02 Runtime"
- install VIVE_SRanipalInstaller_1.0.1.0.msi
- run SRanipal runtime
- attempt calibration, receive error
- wait for SRanipal_update_service to prompt for new version update
- let it update to latest (1.0.3.0)
- restart Steam & SteamVR
- restart SRanipal Runtime
- test if calibration initializes

Link to comment
Share on other sites

 

Thanks for the workaround. We've managed to get this working on a number of different machines now and with both wired and wireless headsets. We did the following (using wired for the initial install):

 

  • We removed SRanipal, Tobii, SteamVR and Steam
  • We ran the VivePro setup.exe (linked via https://www.vive.com/uk/setup/)
  • We then installed VIVE_SRanipalInstaller_1.0.1.0.msi
  • Calibration failed
  • We forced an update (Enterprise environment was blocking update otherwise) by running SRanipal_Update_Service.exe (ran as admin - probably specific to our Enterprise environment)
  • Calibration subsequently suceeded.
Link to comment
Share on other sites

  • 2 weeks later...

Hi , I also have been getting the same initialization error. I found the SRanipal_Update_Service.exe application and ran it as administrator, causing a command terminal to open and close rapidly. How do I know if it is updating successfully and when will I know that it is done?

Link to comment
Share on other sites

  • 2 weeks later...

I had a similar problem, and only could fix it by launching sr_runtime as an administrator. Tried this as a last resort after reading another post in this forum. Previously had been trying to run the SRanipal_Update_Service.exe with no success, unlike others I was not prompted to enter administrator credentials while running the updater. 

 

Link to comment
Share on other sites

  • 3 weeks later...

Hello,

I've just got the Vive Pro Eye and am trying to set it up for eye tracking, but I'm having the same issue- I'm unable to launch calibration even with the workaround, and keep getting "Initialization Failed". When I launch calibration, I see that the robot icon does get launched and I get a notification saying the SR_Runtime service is starting on my host machine, but after a few seconds, the runtime stops, and I no longer see the robot icon.

The workaround also doesn't seem to resolve this, perhaps because the VIVE_SRanipalInstaller_1.0.1.0.msi installer (an older version?) is no longer available for download online. I can only uninstall the SRanipal installer and Tobii runtime, and then reinstall the 1.0.3.1 version, which triggers no forced update. When I try to run SRanipal_update_service.exe in admin mode, it just launches a terminal and quickly terminates- I checked the logs too and it looks like there is no update available, so this doesn't do anything. Have tried updating my graphics drivers, reinstalling Steam along with the SRanipal installer, but to no avail.

 

Is there anything I can do at this point? Is there any place to download older versions of the SRanipal installer and see if that'll work? Or is there a newer version of SRanipal installer coming out that resolves this issue? I've PM'ed you a system report from SteamVR as well, hopefully we can figure out something that will resolve this.

Thanks for the help! 

Edited by vkm22
Link to comment
Share on other sites

  • 2 weeks later...

@Cory_HTC @Daniel_Y

Hello,

I failed calibration initiallization too. When I click right mouse and "About", it says that it's eye camera version is not N/A, and my SR version is 1.1.0.1

Restarting computer, reinstalling VIVE and SteamVR, and all method offered above didn't work for me.

How can I fix it? Will it be OK if I get older version of SRapinal?

 

Edited by MyBug
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...