Jump to content
 
krazanmp

SRanipal Start Calibration fails

Recommended Posts

What to do if the device seems to be missing?  The calibration tool fails to initialize (for driver/SDK 1.0.0.0). 

 

Error log:

[Vive SRWorks] [2019-06-17 10:57:46] [LOG] CreateModule(11) start
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] CreateModule(11) EyeCameraModule exist[0]
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] CreateModule(12) start
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] CreateModule(12) EyePredictionModule exist[1]
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] InitialModule(0) start
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] InitialModule(0) end. error= WORK
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] InitialModule(1) start
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] InitialModule(1) end. error= WORK
[Vive SRWorks] [2019-06-17 10:57:46] [LOG] StartModule(0) start
[Vive SRWorks] [2019-06-17 10:57:47] [LOG] StartModule(0) end. error= WORK
[Vive SRWorks] [2019-06-17 10:57:47] [LOG] StartModule(1) start
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] CreateContext()
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] SRanipal Version 1.0.0.0
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] CreateModule(11) start
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] CreateModule(11) EyeCameraModule end[0]
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] InitialModule(0) start
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] InitialModule(0) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] CreateModule(12) start
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] CreateModule(12) EyePredictionModule end[1]
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] InitialModule(1) start
[Vive SRWorks] [2019-06-17 10:58:28] [LOG] InitialModule(1) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] CreateModule(9) start
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] CreateModule(9) LCameraModule end[2]
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] InitialModule(2) start
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] InitialModule(2) end. error= DEVICE_NOT_FOUND
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] StopModule(2) start
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] StopModule(2) end. error= INVALID_CHANGE
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] StopModule(-1) start
[Vive SRWorks] [2019-06-17 10:58:31] [LOG] UNKONW_MODULE
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(11) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(11) EyeCameraModule exist[0]
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(0) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(0) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(12) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(12) EyePredictionModule exist[1]
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(1) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(1) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(9) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(9) LCameraModule exist[2]
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(2) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(2) end. error= DEVICE_NOT_FOUND
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] StopModule(2) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] StopModule(2) end. error= INVALID_CHANGE
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] StopModule(-1) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] UNKONW_MODULE
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(11) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(11) EyeCameraModule exist[0]
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(12) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] CreateModule(12) EyePredictionModule exist[1]
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(0) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(0) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(1) start
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] InitialModule(1) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:44] [LOG] StartModule(0) start
[Vive SRWorks] [2019-06-17 10:58:46] [LOG] StartModule(0) end. error= WORK
[Vive SRWorks] [2019-06-17 10:58:46] [LOG] StartModule(1) start

Share this post


Link to post
Share on other sites

I had the same problem using the wireless adaptor. I plugged in the headset to the link box ran the calibration and it worked -subsequently it now works every time using the wireless adaptor.

 

Weird bug, but may be the problem if you are using the wireless adaptor.

Share this post


Link to post
Share on other sites

We don't use wireless adaptors here.  We always run hard-wired through a link box (Display Port and USB3 connections) directly between the HMD and the computer.

 

Thanks for the suggestion though.

 

// Mike

Share this post


Link to post
Share on other sites

Yes, that is always the first thing I try when something goes awry.  Also rebooted the machine several times and physically unplugged the cables from the link box and the computer.  Swapped USB port.  Etc.

 

   

Share this post


Link to post
Share on other sites

We are having similar issues and have been talking with customer support - so far with no resolution. Whenever we try eye calibration it fails to initialise.

 

The log file says that there is no eye tracking camera present on our hmd so tested this on another machine to be sure and eye tracking worked fine - so the headset isn't the issue.

Have tried restarting, and removing steam fully and reinstalling via the vive pro setup.

Any ideas?

Share this post


Link to post
Share on other sites

This is exactly our experience as well.

 

The log file says that there is no eye tracking camera present on our hmd - Same here

so tested this on another machine to be sure and eye tracking worked fine - Same here


Have tried restarting, - Same here

and removing steam fully and reinstalling via the vive pro setup. - Same here

 

Also uninstalled SRanipal and reinstalled it at 0.8.1.x, 1.0.0.x, 1.0.1.x and 1.0.3.x

Also uninstalled SRanipal and deleted any file or folder on the machine with SRanipal in the name and reinstalled it at 0.8.1.x,  1.0.0.x, 1.0.1.x and 1.0.3.x

Also uninstalled any Tobii and deleted any file or folder on the machine with Tobii in the name and allowed the SRanipal installer (all 4 versions) to reinstall it as it wishes.

 

The result is always the same "Whenever we try eye calibration it fails to initialise." AND the provided demos also fail to startup on one machine but works fine on another.

 

Share this post


Link to post
Share on other sites

Sorry to hear you are having some issues on specific PCs. Let's try to narrow down the issue and get it working for you! Here are some questions and suggestions to get started:

 

Are you using Windows 8.1 or later (64-bit)?
What version of SteamVR are you using?
Do you have admin rights on the logged in account? Do you see and accept the Windows UAC popup?
Do you have the robot face icon in the notification tray?
With the Pro Eye plugged in and link box powered on, does the notification icon robot have black eyes or are they green/red?
If you right-click the notification icon and select "About", what eye camera version is shown or is it "N/A"?


Can you try uninstalling these:
- Tobii VRU02 Runtime
- VIVE_SRanipalInstaller

Restart PC.
Install latest runtime (VIVE_SRanipalInstaller_1.0.3.0.msi)

Plug in HMD and wait for any updates to complete.


If you are still having issues can you post or PM me a SteamVR system report?
SteamVR > Settings > General > Create System Report

 

   

Share this post


Link to post
Share on other sites

 

Thanks for the help here. Have just followed your steps and still it is not working. Here are my details and will DM you the logs both the SteamVR generated ones and the SR Logs.

Windows Version: - Windows 10 v1903

SteamVR: - 1.5.9

Admin Rights: Enterprise managed system with DefendPoint but with elevated permissions (note these were the same on the laptop - Razer - working on same Enterprise environment with Eye tracking working fine).

Robot Face: Yes - with orange eyes which means idle

About: Eye Camer Version 1.88.0-8106667

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...