Jump to content

Can't install Intel WiGig

Recommended Posts

I tried running the wigig_installer directly, that failed too.


at one point i think i stopped the installation mid way so it seems half the drivers are installed and it is refusing to over write the drivers. 

What did NOT WORK

uninstall steam vr and re installing


running the wigiginstaller_vr_x64.msi directley (with or without compatiblity) 


i deleted some wigig .inf file in the windows/system32 folder, and i tried to delete any registry (by clicking windows + r and typing "regedit") that contains the word "wigig"

i think deleting the inf file did it for me, because now i am able to reinstall the drivers and it is recognized correctly in the device manager, finally. now to continue installing the wireless !!

Link to post
Share on other sites

I have also tried everything else different PCIe slots X1 X16 Gen2/Gen3 and Steam VR reinstall ... no reformatting but I did a fresh install to a second partition ... all no luck I will have to try your delete .ini and clean registry of any WiGig references next. Thanks for posting this 

Link to post
Share on other sites
  • 1 month later...

I have the same problem. VIVE support is totally useless they even don't know abou this issue at all.


Me:12:05 PM
Cannot install Wigig 
Nathalie C. :12:06 PM
Hello, thank you for contacting Vive technical support. I’ll be more than glad to assist you today. 
Nathalie C. :12:06 PM
How may I help you? 

Me:12:06 PM
hi I have a problem with WiGig. I cannot install the driver. 
Nathalie C. :12:06 PM
Can you please be more specific? 

Me:12:07 PM
when I install the vivewireless setup file, it shows an errro with installing wigig. 
Me:12:07 PM
Fial to install intel WiGig 
Me:12:07 PM
Nathalie C. :12:08 PM
I understand. Have you tried with another PCIe slot? 
Me:12:08 PM
3 different slots 
Nathalie C. :12:09 PM
Still the same? 
Me:12:09 PM
Nathalie C. :12:11 PM
Okay, one last question. When and where did you buy the wireless adapter? 
Nathalie C. :12:11 PM
Okay, one last question. When and where did you buy the wireless adapter? 
Me:12:11 PM
a week ago? from Connection (prev. govconnection) 
Nathalie C. :12:13 PM
I understand. Basically, it is not recognizing the WiGig card since it seems to be defective. I advise you to contact the seller and ask for a return or replacement since the WiGig card is pretty much damaged. 
Me:12:13 PM
Me:12:13 PM
It comes with the original box never opened. 
Nathalie C. :12:14 PM
Still, the WiGig card is defective, otherwise, it should have worked with another slot. 
Me:12:15 PM
And it looks like a common problem when I searched about this. Someone just reinstalled Windows and it fixed the issue. Are you guys aware of this problem? 
Nathalie C. :12:16 PM
Personally, this is the first case I get. However, I'll make a follow-up on this to see if there are other customers who have contacted us with the same issue. 
Nathalie C. :12:17 PM
Also, if a Windows fresh install seems to work with this, you can follow this link site to know how to do so. https://www.microsoft.com/en-us/software-download/windows10startfresh 
Nathalie C. :12:18 PM
Thanks for that. Since it's something from the Community, I'll pass over this information here to make sure to find a solution for this in the future. 
I bought two kits and you are saying both cards are defective....interesting. 
Nathalie C. :12:21 PM
Well, it's either the wireless adapter or the PC. 
Nathalie C. :12:22 PM
You can try the Windows fresh install and if not, then please try with another PC Wireless Adapter compatible
Link to post
Share on other sites

I just fixed the problem. What I tried:


reinstall steam and steamVR several tiems. 

tested the card with 4 different PICe slots. 

Deleted all "wigig" entries from my registry.  

tried to install the driver (in C:\Program Files\VIVE Wireless\IntelWiGig) in a comapatibility mode 


None of them worked.


I ran "Run compatitiblility trubleshooter"  -> "test the program". With this, I was able to install the driver. After this, I ran the ViveWirelessSetup and everything is working fine now. 





Link to post
Share on other sites
  • 2 months later...

Yup, all the same issues here! It turned out the drivers from Intel were not completely installed. Windows shut it down for some reason, midway and wouldn't allow for the updates.


In device manager I located the "Unknown" source and clicked to finish the install. Then updated all my Intel drivers and double checked all the Intel apps had been fully executed.


Then, after a restart, permanently deleted all files and downloads of Vive Wireless. Started a fresh download, ran it and all is good.


My takeaway, make sure all the Intel drivers are updated first and windows recognizes the card. Then download the Vive App.


Link to post
Share on other sites
  • 1 year later...

Hi there! How's everyone doing? Man, it's great to be here, to meet all you fine fellow VR sufferers. It's my first post here, but oh ho, not my first problem by a fair margin.

I'm over here with regular Vive and the same wireless adapter everyone else is having issues with. Now, I'm in a weird scenario, let me catch you up.

The HMD LED was solid red, the wireless adapter LED was slow blinking green, the PCIe card LED was solid blue, the battery was fully charged, the HMD was paired with the desktop application, SteamVR said no HMD detected. The wireless adapter desktop application said an update was available.

Now this part sounds dumb, I know, but I foolishly went ahead and tried to update the desktop application. That's where I began to run into real trouble.


Now I can't install the wigig card, the installer gives up and provides no useful information. I've tried the whole thread-worth of suggestions, short of the scorched earth “solution” of working with a clean slate. This bastard worked for years, I'm not about to reinstall and reconfigure an otherwise rock solid windows installation because of a jank Intel product.

Beyond the solutions here, I used a tool to check for unknown hardware, nothing detected but more oddly, it didn't show the intel wiggy doodad. Additionally, no other drivers are being allowed to be installed or updated, so I'm going to do some more weird tests.

I'll report back with my findings and hopefully have a legitimate solution since clearly nobody official is going to be more useful than a kick to the groin.

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...