Jump to content

Unreal Engine 4 Performance


Naitguolf
 Share

Recommended Posts

Hi! I want to share my experience so far with Focus and UE4 as latest beta version.

 

We are using UE4 with the Focus. But the performance is really bad, as with only one 3D object in screen, the fps goes down to 30-40fps.

 

I saw several tips for FPS improvement in the forum, but those are mostly for Unity. There is something for UE4? Maybe tweaking some .ini files, etc?

 

We can add more 3d objects to the scene, and performance goes to 20-30fps mostly. I know the SDK is beta, but I wonder if its possible to know when is going to be release a next version or if the performance can be improved with UE4... or we need to stick with Unity.

 

I am open for any suggestion. Thank you very much!

 

-Nacho

Link to comment
Share on other sites

Same problem for me with UE4, an empty scene is between 30 and 40 fps.

I couldn't find Ocean Wonder in the store?

Are you sure Qin Terracotta and Great Pyramid are made with UE4, they look like Unity apps!

Do you plan to release a version with a better framerate? 

We would like to release an app for the Vive Focus but it s impossible with such a low framerate!

Link to comment
Share on other sites

Thank you Tony.

The main issue we are having is just adding a simple block, the FPS goes down to 30-40. Also frame rate is very inconsistent (moving a lot from 30-40, sometimes lower, sometime bigger.

 

So I also asking anyone who developed it some nice advise to we can compose at least one basic room with high framerate

 

Thanks!

Link to comment
Share on other sites

Hello there,

 

I have no idea of you level with UE4 , VR and mobile projects, so I may say thing redundant to you.

 

Starting with mobile:

You have to start a Mobile project and not convert an existing desktop one.

Some optimisations have been made for this project at start, so if you can: start fresh.

 

Don't use Anti Alias x8 but limit it to x2 first.

Everything post process is very costly. (DOF, Bloom, etc...) So be careful with those.

 

The main issue is always Draw calls on mobile...

 

I do not know how you get 30-40fps with a single cube, I definitely don't, far from it.

I can run all this:

At 40-55 fps... with AA x2 and post process (bloom and DOF)

 

I am actually amazed by the performance of the VF.

On GearVR (on a S9+)  just enabling HDR (For bloom) does tank my fps to 40 with "one sphere"

 

Test this:

Use their project as a base. (the plugin.uproject) That is in the Beta2 SDK file.

And inport your content in there.

It's easy: open your actual project and select your "maps" and "migrate" them to this project.

 

You could also test their "sea of cube" project, you won't get 40fps.

Or maybe your Focus is defective...

 

Report back here!

 

 

Link to comment
Share on other sites

Hi  many thanks for your reply.

 

I attaching a capture. As you can see, FPS is 32. But FPS is not very constant, going up and down.

 

Maybe is defective or maybe I am doing something really really wrong?

 

 

Link to comment
Share on other sites

Mmm....

Can you post a screen with the command:

stat Unit

(Blue print command and "stat Unit" inside, at event begin play)

 

This is the default scene, you haven't done anything special?

 

will be able to properly help you, as I don't do code.

 

But this is indeed strange!

 

Link to comment
Share on other sites

Hi! Sorry for the delayed response.

 

I used this time x2 for AA and it seems better. I can still see the FPS goes down to 3X, but most of the time is 7X.

Its the default scene, plus adding the FPS as text in the menu widget.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...