Jump to content

Bluetooth Link communication failed


Recommended Posts

Hello,

 

As much as I enjoy the Vive when it works, it's getting really frustrating to use it regularly. My most common issue is the bluetooth link not working, which either causes the Base Stations to never go to sleep, or not wake up.

 

Clicking Restart obviously doesn't do anything. I tried power cycling everything. Link box first then stations, and the other way around. Tried uninstalling the drivers and re-installing them, unchecking the "use bluetooth" in the settings and re-checking it.

 

Is there a magic solution I'm unaware of? A very specific sequence of actions to make this work, ideally without having to do it everytime I use the Vive? The Base stations are quite loud so putting them to sleep is pretty important (not to mention power consumtion), and I would like to avoid un/plugging them from the wall everytime I want to jump into VR.

 

Specs:

Windows 10 (updated)

Intel i5-4440 / ASUS MO / 16GB RAM

GTX 970 (drivers updated)

Link to post
Share on other sites
  • Replies 23
  • Created
  • Last Reply

Top Posters In This Topic

I was having this problem too, I gave up on the bluetooth thing and turned off that feature, I just have my lighthouses plugged into a switched power bar (one for each lighthouse) and at one of them, I also have the Vive's power plugged in also. So when I'm not using the Vive, I just turn off the two power bars and unplug the Vive's USB. Everything's been working well since, that Bluetooth option seems to be more of a pain than what it's worth. I did have it working decently at one time, but after a SteamVR update, it never did work properly afterwards, there has been many SteamVR updates since but I just can't be bothered to have the headaches to get it to work properly.

Regards: Jack

Link to post
Share on other sites

 

The Vive system is composed of about 9 different USB drivers, including Bluetooth, controllers, camera, receivers and audio, among others. Due to different reasons, like software updates, change of connections, system updates or malfunction of a device, the USB drivers might get into conflict and reinstalling them is a good way to get everything back to its working state.

  1. Go to SteamVR > Settings > Developer.
  2. Click on Remove All SteamVR USB Devices.
  3. Once finished, the program will prompt a confirmation of the process.
  4. Disconnect the Link box AC Adapter and the Link box USB cable from the computer.
  5. Close SteamVR.
  6. Connect the AC Adapter back to the Link box and then connect the USB cable directly to the computer to a USB 2.0 port.
  7. Open SteamVR and check if all the devices all properly recognized, by going to SteamVR > Settings > USB > Refresh.
    1. These are the default drivers:

 

Vive Link Box:

·         Hub

·         Hub Controller

·         Bluetooth

 

Vive Headset:

·         Watchman Board

·         Camera

·         Audio Device

·         Main Board

·         Wireless Receiver 1

·         Wireless Receiver 2

 

Note: This list includes the drivers of the devices directly connected to the computer by USB, as it is the HMD and Link box. Controllers and Base Stations are connected to the headset through Bluetooth and then to the computer, so these devices are not going to be visible on this list.

Try the steps above and see if that works for you.

Thanks,

-John C

Link to post
Share on other sites

Hi John,

 

Thanks so much for the reply. I took a few days to reply since I wanted to give it some usage time before replying.

It initially worked, however unfortunately it doesn't seem like a "solution", but rather only a temporary fix.

After doing that everything seemed to have went back to normal, but after a few days the issues came back - sometimes not waking up from sleep (forcing me to unplug and then replug the base stations), and sometimes not going to sleep.

Perhaps unrelated, but it seems like the headset is being kept on at all times as well (green light on the side, headset getting warm).

 

I've taken to just unplugging and replugging everything every time - this is a major pain and definitely not a consumer-grade solution, but I don't see this working any other way.

 

Thanks again,

 

Ev

Link to post
Share on other sites
  • 10 months later...

All solutions works for me only until i reboot my pc.

 

But i solved this problem when i just changed the vive box from a usb3 to a usb2 port.

 

Maybe a incompatibility with my motherboard (asus sabertoth 990x r2) and your asmedia usb3 driver.

Link to post
Share on other sites
  • 4 months later...

Hi,

 

So I never got the bluetooth base station power management to work, until today. I moved the link box USB plug from my USB 3.1 to one of my USB 3.0. And now it properly identifies my base stations when I scan for them.

 

Asus motherboard. Windows refuses to tell me the model, and it's been so long since I bought it. Sorry.

Link to post
Share on other sites
  • 3 weeks later...

I had this problem as well. I followed most of the guides on here and it would only temporarially fix it. After a while someone mentioned here or another forum that it might be windows bluetooth or the onboard bluetooth interfering. It actually was. In windows 10 I went to settings then airplane mode (don't turn airplane mode on) and turned off bluetooth in there. That turned off the windows blue tooth and it fixed my problem. 

 

Not the problem with this is, is it turns off blue tooth everything but the vive bluetooth. I am personally alright with this, but others might not be depending on how you use stuff. I use corded everything so I don't need bluetooth for anything else. 

Link to post
Share on other sites

I can't find update button so I will reply. After a restart I had the issue with bluetooth again. Looks like the temporary fix is as follows:

 

Every time you want to start up VR go into settings, then bluetooth and turn on then off windows bluetooth.

 

This is a hassle, but it is working for me each time. I don't' know what is the deal with why bluetooth is acting like this.

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...