Jump to content
 

Gosbot

Verified Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Gosbot

  • Rank
    Settler

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Update: I found the exact cause of the scenario I’ve been describing. It’s hardware-accelerated GPU scheduling, a recently added feature to Windows that claims to “reduce latency and improve performance.” If you’re using this feature, you probably want to disable it. If you aren’t and you still have performance issues that have arisen recently, I don’t know what to recommend other than the generic troubleshooting techniques like resetting the HMD from the console and checking your SteamVR resolution settings. From my benchmarking, Cosmos 1.0.11.2 and 1.0.12.10 Beta run pretty much the same, though it’s always possible that might be different on your system.
  2. Yup. Interacting with any application that isn't the one running in the VR headset does the trick, even just hitting the Windows key to bring up the start menu. If you want to see if it helps you out at all, I would set the headset on the floor in any area of a certain game where you are having performance issues and then bring up the SteamVR performance graph. If clicking in and out of the application seems to correlate with trends on the graph (for me, the graph would be purple with the game window active, and green after clicking out of the window), you are probably affected with the same issues I am.
  3. Here’s my conclusion on the recent state of performance regarding Cosmos. Every time that the VR application that opens on the desktop when you launch a game is the active window on the PC, performance tanks inside the VR headset. The SteamVR performance graph becomes purple, and the visual experience within the HMD becomes a blurry, stuttering nightmare- that is, if the application is intensive enough in the first place. I used the VRMark Blue Room to benchmark, and the difference between running the program as the active window vs in the background on the PC was astronomical. I got similar results in Half Life: Alyx and Boneworks. So, why does it seem like performance has tanked in newer versions of the Cosmos software? I’ve been able to test 1.0.11.2 and 1.0.12.4a side by side (thank you, @C.T.) and I don’t think that it’s the version of the software itself that has affected performance. With both versions, I would get severe lag until I prevented my game from being the active window, which would then return my performance to the silky smooth experience I remember from when I first got my Cosmos Elite in April. Instead, there is probably a more general issue with how any version of the software interacts with newer versions of SteamVR or Windows such that when launching games from within the headset, they now launch as the active window. I am convinced that games did not, for one reason or another, launch this way at one point, since I used to always get the great performance that I now have to take an extra step to achieve. TL;DR- Running VR applications as the active window on the PC tanks performance in the Cosmos. Launching games from within the headset makes them the active window on your PC by default, which I don’t think used to happen. To fix your VR performance, open a browser tab on your computer to ensure that the VR game isn’t the active window. All my testing was done on a system with a GTX 1070, R5 3600, and 16 GB of RAM on Windows 10 2004. I cannot guarantee that this fix will work for everyone, but I am positive that it worked for me. This fix would also explain why some people have claimed that changing process priorities in task manager resolved their performance issues. It's not the actual changes they make in task manager that help them, it's that opening task manager involves them stopping the running VR app from being the active window.
  4. Thanks, I ran a benchmark of my current performance and messaged you so that I can try testing if there's any difference between it and 1.0.11.2.
  5. Performance isn't any better for me. I wish we had the ability to roll back to older versions of the software so that I could test the extent to which my performance has degraded since 1.0.12.4a and make sure there isn't something wrong on my end.
  6. Fixed it! I had to go to my Windows camera privacy settings, and then turn on camera access for the device and desktop apps. I never had to do this before, but I'm now positive that it's what was causing the problem. The ViveVRServer appears on the list of desktop apps that wants to access my camera, and I can replicate and then fix the black screen issue by toggling its permission off and on. @Captain Patate I hope this works for you, if it doesn't I would check to see if you have any other programs or settings that could affect camera access on your computer.
  7. Report completed. Trace number: 20200604160400
  8. Hello, As of June 2 my Cosmos Elite display will no longer show anything but black. To be clear, it is not pitch black as if the headset was powered off completely. Instead, the display turns on, but will only show black. However, my desktop VR view is accurate, and shows content as expected. Neither SteamVR nor the Vive Console report any errors. Both base stations, both controllers, and the headset show a green status light. Everything worked fine on June 1, but after the updates to Steam and the Vive Software that took place yesterday the headset display refuses to show anything. As a result, I doubt that the issue is hardware related. I've tried reinstalling the Vive Software and SteamVR multiple times to no effect. I've unplugged and re-plugged everything. My system configuration is as follows, running the latest available Windows 10 update and GPU/CPU drivers: AMD Ryzen 5 3600 EVGA GeForce GTX 1070 FTW MSI X470 Gaming Plus Max 16GB DDR4 RAM Any help is appreciated.
×
×
  • Create New...