Jump to content
 

zzy

Employee
  • Content Count

    124
  • Joined

  • Last visited

Community Reputation

13 Good

About zzy

  • Rank
    Builder

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi @Xyah Thanks for the test. Since the deep learning model are quite computational heavy, it's natural that it might eat up a lot of GPU resources. If you want to use lighter version of Hand Tracking, you can change the mode of hand tracking to 3D Point, which should be much faster than skeleton mode, although returns limited result. We plan to release new version before end of this month, which should bring some performance improvement. You can have a test when the new version is released. We will also keep improving performance, as there are several items in our backlog, but considering current SDK status, accuracy might take higher priority. Here are some references: Different between different modes: https://hub.vive.com/storage/tracking/overview/feature.html#hand-positions-modes Information about how to change mode in Unreal: https://hub.vive.com/storage/tracking/unreal/usage.html#start-stop-detection
  2. Hi @Xyah I have tested using our test machines (1060 & 2060) today. I'll answer your question first and then update my findings. You can find the prebuilt samples in the zip you downloaded from here: https://developer.vive.com/resources/knowledgebase/vive-hand-tracking-sdk/. "Prebuilt samples" folder contains binaries built using Unity. I think this requires camera API to support input resolution settings, but currently no API has such support (SteamVR or Vive Console), so we probably can do nothing about this. We did some performance tuning, but I think that not this big to solve your problem. About my findings, I think this might be a problem from Unreal side instead of hand tracking sdk. Here is my experiment, I use SteamVR frame timer to check the FPS and GPU times. In all my experiments, CPU is the bottleneck. I run Unity sample on 1060 & 2060, GPU time is larger when hands are visible, but the frame time is within 11ms (90 FPS). I run Unreal app, GPU time is significantly larger than Unity version, about 2x times are used in GPU. I tried to create a new default level, without hand related stuffs. It consumes very large GPU times, even worse than Unity sample with hand. This makes me think the problem is on Unreal side. Please let me know if this is the same situation on your side.
  3. Hi @Xyah Thanks for the test. As far as I know, there is no way to change camera resolution of original Cosmos. From your results, it seems the FPS drop only happens when hand is visible. We will check if we can reproduce it on our side. Meanwhile, can you confirm if it's same behavior in Unreal and Unity (pre-built sample)?
  4. Hi @aze I'm not sure if this is a Unity bug, but it seems using Unity 2019.1 is a workaround for now. @Cotta Can you please also help to see if there is any workaround in WaveVR? It seems memory leak happens with WaveVR prefab in some Unity versions.
  5. Hi @Xyah Are you using Cosmos XR or original Cosmos? Camera resolution of original Cosmos is similar to Vive Pro, so I think it's not the root cause. Here are some questions/suggestions for the general frame drop problem: How about running the pre-built sample (built by Unity) and see if there is frame drop? You can use SteamVR to check if there is frame drop. I would like to know if this is specific to Unreal or not. We do have a test laptop with 1060, but Unity sample seems to be working fine with Vive Pro, Cosmos and Cosmos XR. Does it mean that Vive (or Vive Pro?) works fine on your PC without frame drop? Can you check if the frame drop is CPU bounded or GPU bounded? We also uses some CPU resources in our pipeline, and if CPU is 100%, this can easily cause lagging. From what I know, if Vive Console is running for a long time, it may use up to 100% CPU and slows down the PC. You can restart Vive Console in such case.
  6. Hi @BruhMoment I assume you are using Vive/Vive Pro, please follow the steps here to setup your steamvr for first time use: https://hub.vive.com/storage/tracking/misc/steamvr.html I would suggest to read the our document first before develop, especially how to setup up the project and other settings: https://hub.vive.com/storage/tracking/unity/setup.html
  7. Hi @Tima I've spent some time to check if we can support x86 in our current code base. There are some blockers: There are currently some dependencies (internal and external) missing x86 support. Performance of x86 is worse than x64, we need some time for tuning before release. Please note even after tuning, x64 still runs faster than x86. Based on the current situation, I would expect at least 2-3 months before we can release the x86 version.
  8. Hi @Tima We only support x64 binaries in our SDK release for Windows due to the following reasons: Most VR developement tools supports x64 (Unity, Unreal) and are dropping x86 supports. VR applications usually can benefit from 64 bit advantages. Our QA process can be simplified.
  9. Hi everyone, Vive Hand Tracking SDK has a new release v0.9.2 today. You can download it from here. Highlight of changes: Update deep learning models for all platform. Add pinch support and confidence value in hand result. Added support for Cosmos XR faceplate. Added a cartoon hand model. Add new demo for UI interaction. For detailed changes, please refer to release notes.
  10. Hi @LeRuf After a few searching with Google, I think this might be a bug of Unity. Here are related issues and forum discussion: https://issuetracker.unity3d.com/issues/android-crash-with-gsl-mem-error-kgsl-sharedmem-alloc-ioctl-failed-on-adreno-gpu-devices-1 https://issuetracker.unity3d.com/issues/android-crash-with-gsl-mem-error-kgsl-sharedmem-alloc-ioctl-failed-on-adreno-gpu-devices https://forum.unity.com/threads/fixed-memory-issues-on-android-since-2018-3-0f2.599551/ Although the issues are claimed to be fixed, but people are still experiencing this bug. You can even find people taking about Focus Plus in the first link. Recommended solution: You can try the latest 2019.3 version (which should be 2019.3.13 according to this page: https://unity3d.com/cn/get-unity/download/archive) I would recommend using 2018.4 LTS version for stability. You to create a bug report to Unity to see if this can be fixed.
  11. Hi @LeRuf Yes, this seems like a memory leak. I'll try to see if I can reproduce it on my local side tomorrow.
  12. Hi @LeRuf From the log your pasted, I think the problem is here: This seems like a out of memory. Some ways to fix: Build the app for arm64 using il2cpp. It should have more memory available than armv7. Remove some objects from the scene. I think some player settings can also help this, e.g. vertex compression, reduce number of shaders, etc.
  13. Hi @LeRuf Can you share the version of Vive Hand Tracking SDK and WaveVR SDK? Please also provide the adb log about the crash, so we can help to analyze it.
  14. Hi @darkfyrealgoma Yes, Cosmos Elite is supported, it should be working fine using Vive Hand Tracking SDK 0.9.1 or newer. The tracking performance is same as the original Cosmos.
  15. Hi @coloal HandModel scene does work on Android phone, since this scene requires skeleton mode which is not supported on Android phone now. I haven't used it with Vuforia or AR engine. Since we use NDK camera to get rear camera image, and Android only support one consumer for each camera, I think this will not work with other SDKs that also use rear camera.
×
×
  • Create New...