Jump to content
 

musk

Verified Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About musk

  • Rank
    Settler

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I'm trying to deploy my app to Beta on Viveport. I can build and run it on the device with no problems, but when I upload it to Viveport it fails and gives me a rather unhelpful error message: Deploying to Beta Failed Failed to deploy this build, please make sure the package name and android manifest are correct. Click “Edit” to make adjustments and submit again. For additional support, please contact us. Error code: -5 I can't see anything wrong with my manifest, here's what it looks like: <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.unity3d.player" xmlns:tools="http://schemas.android.com/tools"> <application android:icon="@drawable/app_icon" android:label="@string/app_name" android:theme="@style/Theme.WaveVR.Loading" android:resizeableActivity="false" tools:replace="android:theme"> <activity android:name="com.htc.vr.unity.WVRUnityVRActivity" android:label="@string/app_name" android:enableVrMode="@string/wvr_vr_mode_component" android:theme="@android:style/Theme.NoTitleBar.Fullscreen" android:launchMode="singleTask" android:configChanges="orientation|keyboardHidden" android:screenOrientation="landscape"> <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> <category android:name="com.htc.intent.category.VRAPP" /> </intent-filter> <meta-data android:name="unityplayer.UnityActivity" android:value="true" /> <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="true" /> </activity> <meta-data android:name="minWaveSDKVersion" android:value="1" /> <meta-data android:name="com.htc.vr.content.NumDoFHmd" android:value="6DoF"/> <meta-data android:name="com.htc.vr.content.NumDoFController" android:value="3DoF"/> <meta-data android:name="com.htc.vr.content.NumController" android:value="1"/> <meta-data android:name="no_controller_pairing" android:value="true" /> </application> <uses-permission android:name="android.permission.INTERNET" /> <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" /> <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" /> <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" /> <uses-permission android:name="com.htc.vr.core.server.VRDataWrite"/> <uses-permission android:name="com.htc.vr.core.server.VRDataRead"/> <uses-permission android:name="com.htc.vr.core.server.VRDataProvider" /> <uses-permission android:name="vive.wave.vr.oem.data.OEMDataRead" /> <uses-permission android:name="vive.wave.vr.oem.data.OEMDataWrite" /> <uses-permission android:name="com.viveport.CHECK_LICENSE" /> <uses-feature android:glEsVersion="0x00030000" /> <uses-sdk android:minSdkVersion="25" android:targetSdkVersion="26"/> </manifest> I'm using Unity 2019.2.19 and Wave SDK 3.1.4. I have another app that uses an older version of the Wave SDK and has identical manifest, except for targetSdkVersion, which in that case is 25. I tried changing to 25 in this app as well, but the build fails and WaveSDK dialog complains that the recommended setting is 26. I attached a screenshot from Unity's console when trying to build with target=25. @JustinVive @Cotta @Tony PH Lin @Albert H. @Corvus
  2. In my experience, the only way I ever got it working was by deleting the old version, and then importing the new one. I don't know about the newest WaveSDK version though, I'm currently on 3.0.2. I did succesfully update this way to 3.1.1 (Beta), but then I couldn't build the application anymore, and some of WaveSDK components were overriding some of my own in the editor, like camera movement. This SDK was always a giant headache and source of problems in projects I worked on.
  3. I don't know if you're using Unity, but if so, then maybe what you want is the OnApplicationFocus(bool focus) callback? I use it in my game and it works for detecting when user leaves the application (goes to Home, Library, Settings etc), but I haven't tested if it detects when user takes the headset off.
  4. I don't think the error "[EGL] Unable to acquire context (...)" has anything to do with this issue, because I always get a whole bunch of them when a scene is loaded. It's super annoying because I have an in-game debug display and it gets spammed with these errors making it hard to see any useful ogs at the beginning of the game. I've been using Wave SDK 3.0.2 and various versions of Unity, currently 2018.4.5. However I also tested my game on Unity 2019.1.X a couple times and didn't have any issues, though I had to make a small tweak to BuildCheck script to make it work at all... In case it helps anyone, the tweak was to add Application.unityVersion.StartsWith("2019.") to this if statement: if (Application.unityVersion.StartsWith("2017.") || Application.unityVersion.StartsWith("2018.")) @Cotta @Tony PH Lin
  5. @Cory_HTC So when can we expect the Focus to work natively in Unity without the Wave SDK?
  6. I'm still getting 2.2KB of garbage generated every frame by the RenderLoop coroutine (using WaveSDK 3.0.2) when testing on the headset. It is the only source of garbage collection at runtime in my project, and it causes dropped frames every couple seconds, so it's very important to fix this. What's your ETA on this fix?
  7. I have the same problem - making a racing game for the Focus, constant 75fps, but it doesn't matter if I test some of the heavier scenes or the lighter ones where performance could be way above 75fps, I still notice some random judder every now and then.
  8. Hi, Thanks for the update, the .zip file has solved my issue with crashes. However I still get the "Tiled GPU perf." warning, which seems to be caused by the SDK. I noticed it doesn't appear if I check the option in Unity: Edit -> Graphics Emulation -> No Emulation, but that's only evading the issue, not solving it. Here's the full warning as seen in Unity's console window: Tiled GPU perf. warning: RenderTexture color surface (638x368) was not cleared/discarded. See TiledGPUPerformanceWarning.ColorSurface label in Profiler for info UnityEngine.Camera:Render() WaveVR_Distortion:RenderEye(WVR_Eye, RenderTexture) (at Assets/Imported/WaveVR/Scripts/WaveVR_Distortion.cs:127) WaveVR_Render:RenderEye(Camera, WVR_Eye) (at Assets/Imported/WaveVR/Scripts/WaveVR_Render.cs:740) <RenderLoop>d__76:MoveNext() (at Assets/Imported/WaveVR/Scripts/WaveVR_Render.cs:707)
  9. Hi Tony, thanks for Your reply. If you want to know the use case in my current project, I want to change the resolution to reduce aliasing by changing the rendering scale to a higher value. Although, making the scale lower to reduce resolution would also be helpful when performance is more important. For example, I want to set the rendering scale to 1.5, which would render the scene in 4320 x 2400 (since regular resolution on Vive Focus is 2880 x 1600 and we multiply each by 1.5) and then downsample to the display resolution, effectively reducing aliasing. Other anti-aliasing methods didn't work for me as well as I would like, but this might help in my case. In general, it would be best if we could set this rendering scale to any value, any time, even at runtime, but in my case it'd be enough if I could at least set it once for the entire project and not modify it during gameplay.
  10. Hi everyone, is it possible to change the rendering resolution scale on the HTC Focus? I tried using Unity's XR Settings: UnityEngine.XR.XRSettings.eyeTextureResolutionScale = scale; But it doesn't do anything. Didn't find a corresponding option in WaveVR classes.
  11. Hi everyone, looks like every 3rd time I go into Play mode the editor crashes. I tested with Unity 2017.4.14, 2017.4.15 and 2018.2.17 and with WaveSDK 2.1.8. I've configured everything as the guide says, made an empty scene with a default directional light and the WaveVR prefab. The editor doesn't crash if I don't add the WaveVR prefab. I don't have any problems building and running the app either. After hitting "Play" the first time, there's just a couple messages in Console and one warning - Tiled GPU perf. warning: RenderTexture color surface (700x313) was not cleared/discarded. See TiledGPUPerformanceWarning.ColorSurface label in Profiler for info. After going into Play mode the second time, 2 messages keep on appearing (about a 100 times/s): WaveVR_Simulator : send failed with error: 0, skip this transmit WaveVR_Simulator : send failed with error: 10038, skip this transmit Then, when trying to Play again, the editor crashes. I haven't used the Simulator, and when going into WaveVR -> Simulator there's only an option to install apk or start it.
×
×
  • Create New...