Jump to content
 

BelleGueule

Verified Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About BelleGueule

  • Rank
    Settler

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. so when i try to install the ViveWireless driver i get the message "vive wireless needs SteamVR Installed first." as you can see on the picture i have steam vr 1.3.23 installed, ( i have also tried the Beta version with the same result) anyone has an idea how to fix that.? can you move this post in Dev support Thanks :P
  2. it might not be the best solution but we've worked around the issue by tweeking openvr_api.cs public class OpenVRInterop{/* [DllImportAttribute("openvr_api", EntryPoint = "VR_InitInternal", CallingConvention = CallingConvention.Cdecl)] internal static extern uint InitInternal(ref EVRInitError peError, EVRApplicationType eApplicationType); [DllImportAttribute("openvr_api", EntryPoint = "VR_InitInternal2", CallingConvention = CallingConvention.Cdecl)] internal static extern uint InitInternal2(ref EVRInitError peError, EVRApplicationType eApplicationType,[in, MarshalAs(UnmanagedType.LPStr)] string pStartupInfo); [DllImportAttribute("openvr_api", EntryPoint = "VR_ShutdownInternal", CallingConvention = CallingConvention.Cdecl)] internal static extern void ShutdownInternal(); [DllImportAttribute("openvr_api", EntryPoint = "VR_IsHmdPresent", CallingConvention = CallingConvention.Cdecl)] internal static extern bool IsHmdPresent(); [DllImportAttribute("openvr_api", EntryPoint = "VR_IsRuntimeInstalled", CallingConvention = CallingConvention.Cdecl)] internal static extern bool IsRuntimeInstalled(); [DllImportAttribute("openvr_api", EntryPoint = "VR_RuntimePath", CallingConvention = CallingConvention.Cdecl)] internal static extern string RuntimePath(); [DllImportAttribute("openvr_api", EntryPoint = "VR_GetStringForHmdError", CallingConvention = CallingConvention.Cdecl)] internal static extern IntPtr GetStringForHmdError(EVRInitError error); [DllImportAttribute("openvr_api", EntryPoint = "VR_GetGenericInterface", CallingConvention = CallingConvention.Cdecl)] internal static extern IntPtr GetGenericInterface([in, MarshalAs(UnmanagedType.LPStr)] string pchInterfaceVersion, ref EVRInitError peError); [DllImportAttribute("openvr_api", EntryPoint = "VR_IsInterfaceVersionValid", CallingConvention = CallingConvention.Cdecl)] internal static extern bool IsInterfaceVersionValid([in, MarshalAs(UnmanagedType.LPStr)] string pchInterfaceVersion); [DllImportAttribute("openvr_api", EntryPoint = "VR_GetInitToken", CallingConvention = CallingConvention.Cdecl)] internal static extern uint GetInitToken();*/ [DllImportAttribute("__Internal", EntryPoint = "VR_InitInternal", CallingConvention = CallingConvention.Cdecl)] internal static extern uint InitInternal(ref EVRInitError peError, EVRApplicationType eApplicationType); [DllImportAttribute("__Internal", EntryPoint = "VR_InitInternal2", CallingConvention = CallingConvention.Cdecl)] internal static extern uint InitInternal2(ref EVRInitError peError, EVRApplicationType eApplicationType, [in, MarshalAs(UnmanagedType.LPStr)] string pStartupInfo); [DllImportAttribute("__Internal", EntryPoint = "VR_ShutdownInternal", CallingConvention = CallingConvention.Cdecl)] internal static extern void ShutdownInternal(); [DllImportAttribute("__Internal", EntryPoint = "VR_IsHmdPresent", CallingConvention = CallingConvention.Cdecl)] internal static extern bool IsHmdPresent(); [DllImportAttribute("__Internal", EntryPoint = "VR_IsRuntimeInstalled", CallingConvention = CallingConvention.Cdecl)] internal static extern bool IsRuntimeInstalled(); [DllImportAttribute("__Internal", EntryPoint = "VR_RuntimePath", CallingConvention = CallingConvention.Cdecl)] internal static extern string RuntimePath(); [DllImportAttribute("__Internal", EntryPoint = "VR_GetStringForHmdError", CallingConvention = CallingConvention.Cdecl)] internal static extern IntPtr GetStringForHmdError(EVRInitError error); [DllImportAttribute("__Internal", EntryPoint = "VR_GetGenericInterface", CallingConvention = CallingConvention.Cdecl)] internal static extern IntPtr GetGenericInterface([in, MarshalAs(UnmanagedType.LPStr)] string pchInterfaceVersion, ref EVRInitError peError); [DllImportAttribute("__Internal", EntryPoint = "VR_IsInterfaceVersionValid", CallingConvention = CallingConvention.Cdecl)] internal static extern bool IsInterfaceVersionValid([in, MarshalAs(UnmanagedType.LPStr)] string pchInterfaceVersion); [DllImportAttribute("__Internal", EntryPoint = "VR_GetInitToken", CallingConvention = CallingConvention.Cdecl)] internal static extern uint GetInitToken(); }
  3. When in the editor i sometime get Framework init -1, to fix the issue i would simply reboot unity and it would work. i started building today to see if the issue was only in the editor and i was greeted with the DllNotFoundException: ViveSR_API PC Spec: GTX1080 I7-7820HK 16Go Ram I've i done something wrong? unity log Mono path[0] = 'C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Managed'Mono config path = 'C:/Users/[REDACTED]/Desktop/New/MonoBleedingEdge/etc'PlayerConnection initialized from C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data (debug = 0)PlayerConnection initialized network socket : 0.0.0.0 55361Socket: bind failed, error: An attempt was made to access a socket in a way forbidden by its access permissions.(10013) (Filename: C:\buildslave\unity\build\Runtime/Network/Sockets.cpp Line: 415)Multi-casting "[iP] [Redacted] [Port] 55361 [Flags] 3 [Guid] 719054361 [EditorId] 2044941076 [Version] 1048832 [id] WindowsPlayer(OMEN-01) [Debug] 1 [PackageName] WindowsPlayer" to [225.0.0.222:54997]...Waiting for connection from host on [0.0.0.0:55361]...Timed out. Continuing without host connection.Started listening to [0.0.0.0:55361]Using monoOptions --debugger-agent=transport=dt_socket,embedding=1,server=y,suspend=n,address=0.0.0.0:56361PlayerConnection already initialized - listening to [0.0.0.0:55361]Initialize engine version: 2018.3.13f1 (06548a9e9582)GfxDevice: creating device client; threaded=1Direct3D: Version: Direct3D 11.0 [level 11.1] Renderer: NVIDIA GeForce GTX 1080 (ID=0x1ba0) Vendor: VRAM: 8079 MB Driver: 25.21.14.1967Begin MonoManager ReloadAssembly- Completed reload, in 0.123 seconds<RI> Initializing input.<RI> Input initialized.<RI> Initialized touch support.OpenVR initialized! (Filename: C:\buildslave\unity\build\Runtime/VR/OpenVR/OpenVR.cpp Line: 728)Created eye textures with a "separate" layout. The "multi-pass" stereo mode will be used. (Filename: C:\buildslave\unity\build\Runtime/VR/VRDevice.cpp Line: 2264)WARNING: Shader Unsupported: 'Hidden/PostProcessing/Uber' - Pass '' has no vertex shaderWARNING: Shader Unsupported: 'Hidden/PostProcessing/Uber' - Pass '' has no vertex shaderWARNING: Shader Unsupported: 'Hidden/PostProcessing/FinalPass' - Pass '' has no vertex shaderWARNING: Shader Unsupported: 'Hidden/PostProcessing/FinalPass' - Pass '' has no vertex shaderUnloadTime: 0.739900 ms<b>[steamVR]</b> Successfully loaded 10 actions from action manifest into SteamVR (C:/Users/[REDACTED]/Desktop/New/actions.json)UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])UnityEngine.Logger:Log(LogType, Object)UnityEngine.Debug:Log(Object)Valve.VR.SteamVR_Input:IdentifyActionsFile(Boolean) (at [REDACTED]\Assets\SteamVR\Input\SteamVR_Input.cs:1270)Valve.VR.SteamVR:CreateInstance() (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR.cs:179)Valve.VR.SteamVR:Initialize(Boolean) (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR.cs:98)Valve.VR.SteamVR_Behaviour:InitializeSteamVR(Boolean) (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR_Behaviour.cs:116)Valve.VR.SteamVR_Behaviour:Awake() (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR_Behaviour.cs:97) (Filename: [REDACTED]/Assets/SteamVR/Input/SteamVR_Input.cs Line: 1270)<b>[steamVR]</b> Initialized. Connected to lighthouse:LHR-9BDCF81DUnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])UnityEngine.Logger:Log(LogType, Object)UnityEngine.Debug:Log(Object)Valve.VR.SteamVR:.ctor() (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR.cs:618)Valve.VR.SteamVR:CreateInstance() (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR.cs:201)Valve.VR.SteamVR:Initialize(Boolean) (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR.cs:98)Valve.VR.SteamVR_Behaviour:InitializeSteamVR(Boolean) (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR_Behaviour.cs:116)Valve.VR.SteamVR_Behaviour:Awake() (at [REDACTED]\Assets\SteamVR\Scripts\SteamVR_Behaviour.cs:97) (Filename: [REDACTED]/Assets/SteamVR/Scripts/SteamVR.cs Line: 618)Plugins: Failed to load 'C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Plugins/ViveSR_API.dll' with error 'The specified procedure could not be found.'.System.Runtime.InteropServices.Marshal:GetFunctionPointerForDelegateInternal(Delegate)System.Runtime.InteropServices.Marshal:GetFunctionPointerForDelegate(UnityRenderEvent)Vive.Plugin.SR.ViveSR_DualCameraImageRenderer:Start() (at [REDACTED]\Assets\ViveSR\Scripts\ViveSR_DualCameraImageRenderer.cs:92)[C:\buildslave\unity\build\Runtime/Misc/Plugins.cpp line 233] (Filename: [REDACTED]/Assets/ViveSR/Scripts/ViveSR_DualCameraImageRenderer.cs Line: 92)Fallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_API.dllFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_API.dllFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_APIDllNotFoundException: ViveSR_API at (wrapper managed-to-native) System.Runtime.InteropServices.Marshal.GetFunctionPointerForDelegateInternal(System.Delegate) at System.Runtime.InteropServices.Marshal.GetFunctionPointerForDelegate[TDelegate] (TDelegate d) [0x00013] in <d7ac571ca2d04b2f981d0d886fa067cf>:0 at Vive.Plugin.SR.ViveSR_DualCameraImageRenderer.Start () [0x0000c] in [REDACTED]\Assets\ViveSR\Scripts\ViveSR_DualCameraImageRenderer.cs:92 (Filename: <d7ac571ca2d04b2f981d0d886fa067cf> Line: 0)Setting up 4 worker threads for Enlighten. Thread -> id: 648 -> priority: 1 Thread -> id: 4e98 -> priority: 1 Thread -> id: 4720 -> priority: 1 Thread -> id: 472c -> priority: 1 d3d11: failed to create buffer (target 0x2 mode 0 size 0) [0x80070057] //This message repeated 333 times Plugins: Failed to load 'C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Plugins/ViveSR_API.dll' with error 'The specified procedure could not be found.'.Vive.Plugin.SR.ViveSR:ViveSR_InitialFramework() (at [REDACTED]\Assets\ViveSR\Scripts\ViveSR.cs:179)Vive.Plugin.SR.<StartFrameworkCoroutine>d__27:MoveNext() (at [REDACTED]\Assets\ViveSR\Scripts\ViveSR.cs:78)UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)[C:\buildslave\unity\build\Runtime/Misc/Plugins.cpp line 233] (Filename: [REDACTED]/Assets/ViveSR/Scripts/ViveSR.cs Line: 179)Fallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_API.dllFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_API.dllFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_APIPlugins: Failed to load 'C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Plugins/ViveSR_API.dll' with error 'The specified procedure could not be found.'.Vive.Plugin.SR.ViveSR_Framework:Initial() (at [REDACTED]\Assets\ViveSR\Scripts\ViveSR_Framework.cs:58)Vive.Plugin.SR.ViveSR:ViveSR_InitialFramework() (at [REDACTED]\Assets\ViveSR\Scripts\ViveSR.cs:179)Vive.Plugin.SR.<StartFrameworkCoroutine>d__27:MoveNext() (at [REDACTED]\Assets\ViveSR\Scripts\ViveSR.cs:78)UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)[C:\buildslave\unity\build\Runtime/Misc/Plugins.cpp line 233] (Filename: [REDACTED]/Assets/ViveSR/Scripts/ViveSR_Framework.cs Line: 58)Fallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_API.dllFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/ViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_APIFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_API.dllFallback handler could not load library C:/Users/[REDACTED]/Desktop/New/[REDACTED]_Data/Mono/libViveSR_APIDllNotFoundException: ViveSR_API at (wrapper managed-to-native) Vive.Plugin.SR.ViveSR_Framework.ViveSR_Initial() at Vive.Plugin.SR.ViveSR_Framework.Initial () [0x00001] in [REDACTED]\Assets\ViveSR\Scripts\ViveSR_Framework.cs:58 at Vive.Plugin.SR.ViveSR.ViveSR_InitialFramework () [0x00003] in [REDACTED]\Assets\ViveSR\Scripts\ViveSR.cs:179 at Vive.Plugin.SR.ViveSR+<StartFrameworkCoroutine>d__27.MoveNext () [0x00088] in [REDACTED]\Assets\ViveSR\Scripts\ViveSR.cs:78 at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in <780acbdfab1d441d95f18133007790cd>:0 (Filename: <780acbdfab1d441d95f18133007790cd> Line: 0)A Canvas named "debug canva" with a render mode of ScreenSpaceOverlay is being used while VR is also enabled. This Canvas will continue to incur a rendering cost, but will not be visible while in VR. Is this intentional? (Filename: C:\buildslave\unity\build\Runtime/UI/CanvasManager.cpp Line: 922)
  4. Sorry for the double post, i have a deadline pretty close and would love to have more info before saying "WNF third party Limitation"
  5. How can I prevent srwork to play with the position of the scene in unity, an exemple would be to pass from a standing position to a crouch or prone position, you can clearly see the scene moving on the y axis as you do Aka hmd goes down the scene follow It's also noticeable when doing fast movement right left but less Than up down The result I would like is to have an object at 0,0,0 That never move is it possible? might be related to https://community.viveport.com/t5/Vive-SRWorks-SDK/Parallax-effect-when-using-depth-camera-and-virtual-objects/m-p/19502#M388
  6. alright, also was my assumption right that the support provided here was english based? or there is a multi language team handling non english messages?
  7. if it's the same issue that i had, you need to tell windows to use the Nvidia htc vive Playback Device and not the default one, ill try to take some picture once i headset nearby i can't tell you why the default settings doesn't work but this is the work around that worked for me. maybe someone from HTC can actually shine some light on the issue
  8. i use some type of clamp like those one, it works perfectly for my needs, if you have a place to clamp them it would be the best non permanent solution exemple( i picked the first one but i'm sure you can find cheaper one if you search) https://www.amazon.ca/Hyperkin-Clamp-Mount-Vive-Oculus/dp/B01MG4D3O5/ref=sr_1_fkmr2_1?keywords=HTC+Vive+Wall+Mount+Kit&qid=1555602502&s=gateway&sr=8-1-fkmr2 also if you don't have the place to use the clamp, you could use the wall mount with strong double sided(2m kind) tape but i wouldn't try that as my first option i think the wall mount was included with the vive, (i don't remember how we got ours but they look like that)
  9. So this morning while checking the forum i saw someone asking for help in french. i've figure that this was an english forum and translated his message to incrase his chance of getting help but not even 5 minutes after posting the translation i've notice that my message was remove because it was marked as spam. is what i did not allowed or it's just a false positive from the spam filter, and is it also something that was useful to do in the first place? might be related to -> https://community.viveport.com/t5/Developer-Discussion/anti-spam-features-of-this-forum-are-too-strict-simple-edits-to/m-p/29559#M407
  10. this message is only a translation of 's message Hi, I get the following error during reconstruction when trying to export as .obj [cudaReconstruction Engine ] [error 2019-04-18 04:07:45C:/Users] /liyi_zheng/Desktop/GIT/mr[-!-ERROR-!-] _engine/[code: 0xModule/Mi0013]rageDualCameraAPI_Module_Depth/MirageDualCameraAPI/src/multiscale_combine.cu : 256 unspecified launch failureOpenCV: terminate handler is called! The last OpenCV error is:OpenCV(3.4.2) Error: Gpu API call (unspecified launch failure) in cv::cuda::GpuMat::upload, file C:/Users/liyi_zheng/Desktop/opencv342/modules/core/src/cuda/gpu_mat.cu, line 236 Graphic card: NVIDIA 1080 Driver version : 425.31 this graphic card is Pascal compatible normaly. I've tried to compile the source code of the Exemple in C with the version 4.1.0 of OpenCV but it still doesn't work I've tried Debug and Release but both crashes Maybe i've not installed Cuda correclty ? the program works with a small capture like 1000 frames but between 4000 and 24000 it crashes. [Reconstruction Engine] [2019-04-18 04:06:48] [LOG] Frame:24050, FPS:18.082373, #Vert:18625, Stride:16, #Idx:90999
  11. Thanks alot all i had to do was to create my own "vr rig" using the SRwork camera as the frame and it worked perfectly. Thanks again !
  12. Hi, i have an issue where i cant link the SRPlugin with the SteamVR rig in unity, On Play the SRwork Rig deactivate the steamVR player Camera to use his, which causes me problem since i need to see the controller (from the player rig) i could try to overlay both rig to match but doing this for each level seems way too tedious is there a built in way to tell the SRwork to use the PlayerRig camera?
  13. sorry to hijack the post but i dont have access to create my own due to some weird forum permission setup, could you please give me the permission to be able to post my question, thanks!
×
×
  • Create New...