Jump to content
 
Corvus

Vive Pro Eye Calibration Initialization Error Troubleshooting

Recommended Posts

Vive Pro Eye Calibration Initialization Error Troubleshooting

Problem:
Launching calibration shows error: "Initialization Failed"

Solutions:

- Power off/on PC & Link Box.
- Run 'sr_runtime.exe' as Admin. Default install path: 'C:\Program Files (x86)\VIVE\SRanipal'.
- Update SteamVR Runtime.
- Update graphics card drivers.
- Possible issue with some models of MSI laptops fixed with rollback to earlier NVIDIA driver. Fresh install of NVIDIA driver 417.71 (GPU BIOS not being updated and it does not support the latest NVIDIA driver).
- Uninstall 'VIVE_SRaniaplInstaller' & 'Tobii VRU02 Runtime'. Restart and Install latest 'VIVE_SRanipalInstaller_1.1.0.1.msi'. Plug in HMD and wait for any updates to complete.
- Update motherboard integrated Intel Graphics Driver (fixes system reference to incorrect openCL.dll (intel) instead of NVidia).
- Disable integrated graphic card
- Possible issue with wireless adapter, try running calibration with wired.
- Possible issues with early dev kits.

Check System Requirements:
- Use DisplayPort, mini-DisplayPort, or USB-C output from the dedicated GPU.
- Windows 8.1 or later (64-bit).

 

Share this post


Link to post
Share on other sites

Wow, I'm lucky I stumbled onto this. There is no mention in the setup instructions of needing to run sr_runtime.exe as admin, and the error "initialization failed" doesn't offer any information as to what the problem is. Thanks for the tip!

@Corvus @Daniel_Y

Share this post


Link to post
Share on other sites
On 9/7/2019 at 5:08 AM, Corvus said:

Vive Pro Eye Calibration Initialization Error Troubleshooting

Problem:
Launching calibration shows error: "Initialization Failed"

Solutions:
- Power off/on PC & Link Box.
- Run 'sr_runtime.exe' as Admin. Default install path: 'C:\Program Files (x86)\VIVE\SRanipal'.
- Update SteamVR Runtime.
- Update graphics card drivers.
- Possible issue with some models of MSI laptops fixed with rollback to earlier NVIDIA driver. Fresh install of NVIDIA driver 417.71 (GPU BIOS not being updated and it does not support the latest NVIDIA driver).
- Uninstall 'VIVE_SRaniaplInstaller' & 'Tobii VRU02 Runtime'. Restart and Install latest 'VIVE_SRanipalInstaller_1.1.0.1.msi'. Plug in HMD and wait for any updates to complete.
- Update motherboard integrated Intel Graphics Driver (fixes system reference to incorrect openCL.dll (intel) instead of NVidia).
- Possible issue with wireless adapter, try running calibration with wired.
- Possible issues with early dev kits.

Check System Requirements:
- Use DisplayPort, mini-DisplayPort, or USB-C output from the dedicated GPU.
- Windows 8.1 or later (64-bit).

 

I've tried your solutions, including running as admin, updating graphics driver, updating steam, reinstallation. But I'm still having "initialization Failed". Any other suggestions?

 

@Corvus

Share this post


Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...